b18dca0df8
This commit removes the version selection for the busybox package. Busybox is very well maintained, and bugs are typically fixed in a timely fashion. Moreover, regressions are fairly unlikely in this very stable and well-tested tool. Therefore, there isn't a very compelling reason to have a version selection for Busybox since we don't accept such a version selection for the vast majority of other packages, unless there is a strong reason to do so. Consequently, this commit: * Removes the 1.19.4, 1.20.2 and 1.21.1 Busybox versions, patches and default configuration file. * Moves the 1.22.1 patches from package/busybox/1.22.1 to just package/busybox/ like all other packages. * Renames the default 1.22.1 configuration file to just busybox.config. * Adapts the busybox.mk makefile to encode the current version to use. * Adds appropriate options to Config.in.legacy. However, even though the BR2_BUSYBOX_VERSION_1_22_X is removed, we don't add a Config.in.legacy option for it, since it would cause a legacy warning for virtually *all* users as most people are currently using 1.22.x. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
31 lines
1008 B
Diff
31 lines
1008 B
Diff
--- busybox-1.22.1/libbb/time.c
|
|
+++ busybox-1.22.1-date/libbb/time.c
|
|
@@ -68,15 +68,23 @@ void FAST_FUNC parse_datestr(const char
|
|
/* else end != NUL and we error out */
|
|
}
|
|
} else
|
|
- /* yyyy-mm-dd HH */
|
|
- if (sscanf(date_str, "%u-%u-%u %u%c", &ptm->tm_year,
|
|
+ if (strchr(date_str, '-')
|
|
+ /* Why strchr('-') check?
|
|
+ * sscanf below will trash ptm->tm_year, this breaks
|
|
+ * if parse_str is "10101010" (iow, "MMddhhmm" form)
|
|
+ * because we destroy year. Do these sscanf
|
|
+ * only if we saw a dash in parse_str.
|
|
+ */
|
|
+ /* yyyy-mm-dd HH */
|
|
+ && (sscanf(date_str, "%u-%u-%u %u%c", &ptm->tm_year,
|
|
&ptm->tm_mon, &ptm->tm_mday,
|
|
&ptm->tm_hour,
|
|
&end) >= 4
|
|
- /* yyyy-mm-dd */
|
|
- || sscanf(date_str, "%u-%u-%u%c", &ptm->tm_year,
|
|
+ /* yyyy-mm-dd */
|
|
+ || sscanf(date_str, "%u-%u-%u%c", &ptm->tm_year,
|
|
&ptm->tm_mon, &ptm->tm_mday,
|
|
&end) >= 3
|
|
+ )
|
|
) {
|
|
ptm->tm_year -= 1900; /* Adjust years */
|
|
ptm->tm_mon -= 1; /* Adjust month from 1-12 to 0-11 */
|