0fb1b80532
VLC uses Git as its version control system, so it makes sense to use Git formatted patches. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
29 lines
835 B
Diff
29 lines
835 B
Diff
From f87ef7f97e7e35cc1c922d5a3ff2a2275da7c22e Mon Sep 17 00:00:00 2001
|
|
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
Date: Tue, 1 May 2018 22:30:39 +0200
|
|
Subject: [PATCH] Don't assume X11 is available when Qt5 is used
|
|
|
|
libX11 is an optional dependency for the qt4 module.
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
modules/gui/qt4/Makefile.am | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/modules/gui/qt4/Makefile.am b/modules/gui/qt4/Makefile.am
|
|
index 1a564cf1ea..4d12501eb7 100644
|
|
--- a/modules/gui/qt4/Makefile.am
|
|
+++ b/modules/gui/qt4/Makefile.am
|
|
@@ -22,7 +22,7 @@ else
|
|
if HAVE_WIN32
|
|
libqt4_plugin_la_LIBADD += -lole32 -lcomctl32 -luuid
|
|
else
|
|
-libqt4_plugin_la_LIBADD += $(X_LIBS) $(X_PRE_LIB) -lX11
|
|
+libqt4_plugin_la_LIBADD += $(X_LIBS) $(X_PRE_LIB)
|
|
endif
|
|
endif
|
|
if HAVE_DARWIN
|
|
--
|
|
2.14.3
|
|
|