ef02a11939
Backport a patch to disable tcl/tk dependencies when gui support is disabled. Backport and rebase a patch to avoid host poisoning while cross-compiling. Add another local patch when HELP2MAN is missing. Disable uClibc-ng toolchain for now due to issues with bundled gnulib. The license of gnulib is not easy to describe because it bundle several sources files with different license [1][2]. Even if not SPDX compliant, use "gnulib license". [1] https://git.savannah.gnu.org/cgit/gnulib.git/tree/COPYING [2] https://src.fedoraproject.org/rpms/gnulib/blob/rawhide/f/gnulib.spec#_53 See: http://www.jemarch.net/poke-1.0-relnotes.html http://www.jemarch.net/poke-1.1-relnotes.html http://www.jemarch.net/poke-1.2-relnotes.html Signed-off-by: Romain Naour <romain.naour@gmail.com> Cc: Jose E. Marchesi <jemarch@gnu.org> Cc: Luca Saiu <positron@gnu.org> Cc: Yann E. MORIN <yann.morin.1998@free.fr> [yann.morin.1998@free.fr: - propagate BR2_PACKAGE_LIBATOMIC_OPS_ARCH_SUPPORTS dependency to comment - select busybos-show-others ] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
35 lines
903 B
Diff
35 lines
903 B
Diff
From 8ba76a5a7ce311f67890199c5595bc1f626495ad Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@gmail.com>
|
|
Date: Fri, 30 Apr 2021 15:43:59 +0200
|
|
Subject: [PATCH] configure.ac: HELP2MAN replace ':' by 'true' when
|
|
cross-compiling
|
|
|
|
Avoid:
|
|
/usr/bin/make ./../poke/poke
|
|
../run \
|
|
: -p poke --name="The GNU extensible binary editor" \
|
|
./../poke/poke -o ./poke.1
|
|
../run: line 51: exec: :: not found
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index c2f0760a..93769ef9 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -74,7 +74,7 @@ gl_LIBTEXTSTYLE_OPTIONAL([0.20.5])
|
|
if test $cross_compiling = no; then
|
|
AM_MISSING_PROG(HELP2MAN, help2man)
|
|
else
|
|
- HELP2MAN=:
|
|
+ HELP2MAN=true
|
|
fi
|
|
|
|
dnl recfix is part of the GNU recutils suite, and is used in cfg.mk to
|
|
--
|
|
2.30.2
|
|
|