897d07c313
Note that we don't use completely sequential numbers, because patches below 100 are used to address cross-compilation issues in Python, while patches above 100 are used to make more Python modules configurable. [Thomas: fixup commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
25 lines
710 B
Diff
25 lines
710 B
Diff
Add an option to disable the bz2 module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
configure.in | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
Index: b/configure.ac
|
|
===================================================================
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2662,6 +2662,12 @@
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl"
|
|
fi])
|
|
|
|
+AC_ARG_ENABLE(bz2,
|
|
+ AS_HELP_STRING([--disable-bz2], [disable BZIP2]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} bz2"
|
|
+ fi])
|
|
+
|
|
AC_ARG_ENABLE(dbm,
|
|
AS_HELP_STRING([--disable-dbm], [disable DBM]),
|
|
[ if test "$enableval" = "no"; then
|