897d07c313
Note that we don't use completely sequential numbers, because patches below 100 are used to address cross-compilation issues in Python, while patches above 100 are used to make more Python modules configurable. [Thomas: fixup commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
28 lines
1018 B
Diff
28 lines
1018 B
Diff
Don't add multiarch paths
|
|
|
|
The add_multiarch_paths() function leads, in certain build
|
|
environments, to the addition of host header paths to the CFLAGS,
|
|
which is not appropriate for cross-compilation. This patch fixes that
|
|
by simply removing the call to add_multiarch_paths() when we're
|
|
cross-compiling.
|
|
|
|
Investigation done by David <buildroot-2014@inbox.com>.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/setup.py
|
|
===================================================================
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -456,9 +456,9 @@
|
|
if not cross_compiling:
|
|
add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
+ self.add_multiarch_paths()
|
|
if cross_compiling:
|
|
self.add_gcc_paths()
|
|
- self.add_multiarch_paths()
|
|
|
|
# Add paths specified in the environment variables LDFLAGS and
|
|
# CPPFLAGS for header and library files.
|