0945e4913f
Install headers when building statically Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
40 lines
1.6 KiB
Diff
40 lines
1.6 KiB
Diff
From b7c91f761b6d0b79398d0a064d2d6e34de3dfa47 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Tue, 27 Dec 2022 23:12:37 +0100
|
|
Subject: [PATCH] Makefile: add install_libxxhash.includes target
|
|
|
|
Add install_libxxhash.includes to be able to install headers when
|
|
building and installing the static library
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Upstream status: https://github.com/Cyan4973/xxHash/pull/776]
|
|
---
|
|
Makefile | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index cfa5779..2276282 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -557,6 +557,8 @@ install_libxxhash: libxxhash
|
|
$(Q)$(INSTALL_PROGRAM) $(LIBXXH) $(DESTDIR)$(LIBDIR)
|
|
$(Q)ln -sf $(LIBXXH) $(DESTDIR)$(LIBDIR)/libxxhash.$(SHARED_EXT_MAJOR)
|
|
$(Q)ln -sf $(LIBXXH) $(DESTDIR)$(LIBDIR)/libxxhash.$(SHARED_EXT)
|
|
+
|
|
+install_libxxhash.includes:
|
|
$(Q)$(INSTALL) -d -m 755 $(DESTDIR)$(INCLUDEDIR) # includes
|
|
$(Q)$(INSTALL_DATA) xxhash.h $(DESTDIR)$(INCLUDEDIR)
|
|
$(Q)$(INSTALL_DATA) xxh3.h $(DESTDIR)$(INCLUDEDIR) # for compatibility, will be removed in v0.9.0
|
|
@@ -586,7 +588,7 @@ install_man:
|
|
$(Q)ln -sf xxhsum.1 $(DESTDIR)$(MANDIR)/xxh128sum.1
|
|
|
|
.PHONY: install
|
|
-install: install_libxxhash.a install_libxxhash install_libxxhash.pc install_xxhsum install_man ## install libraries, CLI, links and man page
|
|
+install: install_libxxhash.a install_libxxhash install_libxxhash.includes install_libxxhash.pc install_xxhsum install_man ## install libraries, CLI, links and man page
|
|
@echo xxhash installation completed
|
|
|
|
.PHONY: uninstall
|
|
--
|
|
2.35.1
|
|
|