cf4ec89bfb
Remove -Werror from CFLAGS to avoid build failures caused by warnings. Fixes the following autobuild failure on MIPS64 n32/64: http://autobuild.buildroot.net/results/6be/6be075726ac6db0a48dd6b535841ada932c9ffbb/ Reviewed-by: Markos Chandras <markos.chandras@imgtec.com> Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
16 lines
644 B
Diff
16 lines
644 B
Diff
tvheadend: remove -Werror from CFLAGS
|
|
|
|
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
|
|
--- tvheadend-2b649954346aa2e9c81834d500a25c528f31f829/Makefile.orig 2013-11-28 15:52:52.284041848 +0000
|
|
+++ tvheadend-2b649954346aa2e9c81834d500a25c528f31f829/Makefile 2013-11-28 15:53:03.715220194 +0000
|
|
@@ -27,7 +27,7 @@ PROG := $(BUILDDIR)/tvheadend
|
|
# Common compiler flags
|
|
#
|
|
|
|
-CFLAGS += -Wall -Werror -Wwrite-strings -Wno-deprecated-declarations
|
|
+CFLAGS += -Wall -Wwrite-strings -Wno-deprecated-declarations
|
|
CFLAGS += -Wmissing-prototypes -fms-extensions
|
|
CFLAGS += -g -funsigned-char -O2
|
|
CFLAGS += -D_FILE_OFFSET_BITS=64
|