kumquat-buildroot/package/ngrep/0001-Fix-typo-in-configure-in-when-testing-for-use_pcre.patch
Fabrice Fontaine 14c0c37eaf package/ngrep: fix build with libnet
Use pkg-config to find libnet and avoid the following build failure
raised since commit 100ba8351c if
libnet-config is found on the host:

/home/autobuild/autobuild/instance-4/output-1/host/bin/mips64el-buildroot-linux-gnu-gcc -s -o ngrep ngrep.o  tcpkill.o   -lpcap -lnet   -lpcre -L/usr/lib -lnet
mips64el-buildroot-linux-gnu-gcc: ERROR: unsafe header/library path used in cross-compilation: '-L/usr/lib'

While at it, format Upstream tag of other patches

Fixes:
 - http://autobuild.buildroot.org/results/05c916162b9c1027cf53f1699a1f5653151098ed

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2024-02-05 18:48:08 +01:00

25 lines
755 B
Diff

From b8b1e9751e1d074af0dd77c2554c1b25fd8f7abe Mon Sep 17 00:00:00 2001
From: Romain Francoise <romain@rfr.io>
Date: Mon, 1 Jan 2018 18:00:34 +0100
Subject: [PATCH] Fix typo in configure.in when testing for use_pcre
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Upstream: https://github.com/jpr5/ngrep/commit/b8b1e9751e1d074af0dd77c2554c1b25fd8f7abe
---
configure.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.in b/configure.in
index cff37e9..06c050a 100644
--- a/configure.in
+++ b/configure.in
@@ -146,7 +146,7 @@ AC_ARG_ENABLE(pcre,
[ use_pcre="$enableval" ],
[ use_pcre="no" ])
-if test use_pcre = yes; then
+if test $use_pcre = yes; then
USE_PCRE="1"
EXTRA_LIBS="$EXTRA_LIBS -lpcre"
else