59b0aa7a7e
Patch by Dan Lykowski <lykowdk@gmail.com>, closes #181. Minor fixups for kdrive by me.
37 lines
1.1 KiB
Diff
37 lines
1.1 KiB
Diff
--- a/configure.ac 2008-04-09 15:42:55.000000000 -0400
|
|
+++ b/configure.ac 2008-06-23 09:39:06.000000000 -0400
|
|
@@ -87,12 +87,18 @@ if test x$XSERVER_LIBPCIACCESS = xyes; t
|
|
fi
|
|
|
|
if test "$DRI" != no; then
|
|
+ if test "$cross_compiling" = "no" ; then
|
|
AC_CHECK_FILE([${sdkdir}/dri.h],
|
|
[have_dri_h="yes"], [have_dri_h="no"])
|
|
AC_CHECK_FILE([${sdkdir}/sarea.h],
|
|
[have_sarea_h="yes"], [have_sarea_h="no"])
|
|
AC_CHECK_FILE([${sdkdir}/dristruct.h],
|
|
[have_dristruct_h="yes"], [have_dristruct_h="no"])
|
|
+ else
|
|
+ have_dri_h="yes"
|
|
+ have_sarea_h="yes"
|
|
+ have_dristruct_h="yes"
|
|
+ fi
|
|
fi
|
|
|
|
AC_MSG_CHECKING([whether to include DRI support])
|
|
@@ -133,8 +139,12 @@ AC_MSG_RESULT([$XVMC])
|
|
|
|
AM_CONDITIONAL(XVMC, test x$XVMC = xyes)
|
|
|
|
-AC_CHECK_FILE([${sdkdir}/xf86Module.h],
|
|
- [have_xf86Module_h="yes"], [have_xf86Module_h="no"])
|
|
+if test "$cross_compiling" = "no" ; then
|
|
+ AC_CHECK_FILE([${sdkdir}/xf86Module.h],
|
|
+ [have_xf86Module_h="yes"], [have_xf86Module_h="no"])
|
|
+else
|
|
+ have_xf86Module_h="yes"
|
|
+fi
|
|
|
|
# Check the ABI_VIDEODRV_VERSION
|
|
SAVE_CFLAGS="$CFLAGS"
|