7eed608713
Backport 2 patches fixing statx redefinition: In file included from ../src/basic/missing.h:18, from ../src/basic/util.h:28, from ../src/basic/hashmap.h:10, from ../src/shared/bus-util.h:12, from ../src/libsystemd/sd-bus/bus-creds.c:11: /usr/include/linux/stat.h:99:8: error: redefinition of ‘struct statx’ Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
78 lines
2.6 KiB
Diff
78 lines
2.6 KiB
Diff
From 17bd864a04a0583cfb343c5621b591bdd76d79ad Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
Date: Wed, 18 Jul 2018 17:26:17 +0200
|
|
Subject: [PATCH] meson: unify linux/stat.h check with other checks and use
|
|
_GNU_SOURCE
|
|
|
|
Using _GNU_SOURCE is better because that's how we include the headers in the
|
|
actual build, and some headers define different stuff when it is defined.
|
|
sys/stat.h for example defines 'struct statx' conditionally.
|
|
|
|
(cherry picked from commit 9c869d08d82c73f62ab3527567858ce4b0cf1257)
|
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
|
---
|
|
meson.build | 20 ++++++++++++++------
|
|
src/basic/missing.h | 2 +-
|
|
2 files changed, 15 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index a0e724070..5dcabdc6c 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -421,11 +421,9 @@ decl_headers = '''
|
|
#include <uchar.h>
|
|
#include <linux/ethtool.h>
|
|
#include <linux/fib_rules.h>
|
|
-#include <linux/stat.h>
|
|
#include <sys/stat.h>
|
|
'''
|
|
# FIXME: key_serial_t is only defined in keyutils.h, this is bound to fail
|
|
-# FIXME: these should use -D_GNU_SOURCE, since that is defined at build time
|
|
|
|
foreach decl : ['char16_t',
|
|
'char32_t',
|
|
@@ -436,13 +434,23 @@ foreach decl : ['char16_t',
|
|
]
|
|
|
|
# We get -1 if the size cannot be determined
|
|
- have = cc.sizeof(decl, prefix : decl_headers) > 0
|
|
+ have = cc.sizeof(decl, prefix : decl_headers, args : '-D_GNU_SOURCE') > 0
|
|
+
|
|
+ if decl == 'struct statx'
|
|
+ if have
|
|
+ want_linux_stat_h = false
|
|
+ else
|
|
+ have = cc.sizeof(decl,
|
|
+ prefix : decl_headers + '#include <linux/stat.h>',
|
|
+ args : '-D_GNU_SOURCE') > 0
|
|
+ want_linux_stat_h = have
|
|
+ endif
|
|
+ endif
|
|
+
|
|
conf.set10('HAVE_' + decl.underscorify().to_upper(), have)
|
|
endforeach
|
|
|
|
-conf.set10('HAVE_STRUCT_STATX_IN_SYS_STAT_H', cc.sizeof('struct statx', prefix : '''
|
|
-#include <sys/stat.h>
|
|
-''', args : '-D_GNU_SOURCE') > 0)
|
|
+conf.set10('WANT_LINUX_STAT_H', want_linux_stat_h)
|
|
|
|
foreach decl : [['IFLA_INET6_ADDR_GEN_MODE', 'linux/if_link.h'],
|
|
['IN6_ADDR_GEN_MODE_STABLE_PRIVACY', 'linux/if_link.h'],
|
|
diff --git a/src/basic/missing.h b/src/basic/missing.h
|
|
index 14ad3d491..9044683b1 100644
|
|
--- a/src/basic/missing.h
|
|
+++ b/src/basic/missing.h
|
|
@@ -24,7 +24,7 @@
|
|
#include <uchar.h>
|
|
#include <unistd.h>
|
|
|
|
-#if !HAVE_STRUCT_STATX_IN_SYS_STAT_H
|
|
+#if WANT_LINUX_STAT_H
|
|
#include <linux/stat.h>
|
|
#endif
|
|
|
|
--
|
|
2.14.4
|
|
|