89502b9d56
[Thomas: - Rename patch to the proper naming convention - Reduce patch to only take care of the IPv6 case - Add description in the patch - Propagate libglib2 dependencies in Config.in + added the corresponding comment. - Added a real help text, and fixed the help text indentation. - Fixed the comment header in the .mk file to have the right number of # signs. - Added the license informations - Added a dependency on host-pkgconf, used by the configure script - Added --without-gstreamer and --without-gstreamer-0.10 to be explicit about the fact that we don't support GStreamer in libnice for now. - Fixed the hash file to have the proper format.] Signed-off-by: Gregory Dymarek <gregd72002@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
21 lines
587 B
Diff
21 lines
587 B
Diff
Make libnice build in non-IPv6 configurations
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/stun/usages/bind.c
|
|
===================================================================
|
|
--- a/stun/usages/bind.c
|
|
+++ b/stun/usages/bind.c
|
|
@@ -260,9 +260,11 @@
|
|
case AF_INET:
|
|
setsockopt (fd, SOL_IP, IP_RECVERR, &yes, sizeof (yes));
|
|
break;
|
|
+#ifdef IPV6_RECVERR
|
|
case AF_INET6:
|
|
setsockopt (fd, SOL_IPV6, IPV6_RECVERR, &yes, sizeof (yes));
|
|
break;
|
|
+#endif
|
|
default:
|
|
/* Nothing to do. */
|
|
break;
|