0d4133edfe
Until now, the gettext source code was being patched differently for the host and the target build, which is going to be incompatible with out-of-tree build. The difference is that the gettext tools could be disabled in the target build, but are always enabled on the host build. Therefore, this commit switches the gettext package to using proper patches against the relevant configure.ac and Makefile.am files. gettext is now being autoreconfigured. Configuration options are also passed for the host variant, in order to disable the build of a large number of things we don't care about. Finally, the two existing patches are renamed to include a number in their filename. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
15 lines
690 B
Diff
15 lines
690 B
Diff
--- gettext-0.16.1.oorig/gettext-tools/gnulib-lib/error.h 2006-11-27 18:14:50.000000000 +0100
|
|
+++ gettext-0.16.1/gettext-tools/gnulib-lib/error.h 2007-06-20 13:29:32.000000000 +0200
|
|
@@ -50,7 +50,10 @@ extern void error_at_line (int __status,
|
|
/* If NULL, error will flush stdout, then print on stderr the program
|
|
name, a colon and a space. Otherwise, error will call this
|
|
function without parameters instead. */
|
|
-extern DLL_VARIABLE void (*error_print_progname) (void);
|
|
+#ifndef __UCLIBC__
|
|
+extern DLL_VARIABLE
|
|
+#endif
|
|
+void (*error_print_progname) (void);
|
|
|
|
/* This variable is incremented each time `error' is called. */
|
|
extern DLL_VARIABLE unsigned int error_message_count;
|