298cd8eaa2
Autogenerated from rename-patch.py (http://patchwork.ozlabs.org/patch/403345) Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
76 lines
2.8 KiB
Diff
76 lines
2.8 KiB
Diff
From 298356c44a7df2b34c4e307c531d2010e2cb4b79 Mon Sep 17 00:00:00 2001
|
|
From: Lionel Orry <lionel.orry@gmail.com>
|
|
Date: Wed, 27 Mar 2013 15:56:56 +0100
|
|
Subject: [PATCH 1/1] Fix Makefiles for cross-compilation
|
|
|
|
The CFLAGS handling in mongrel2 is really messy and it is hard to make
|
|
it behave correctly with cross-compiling environments. This patch
|
|
restricts the Makefiles syntax to GNU Make, but help cross-compiling.
|
|
|
|
This is not meant to be applied upstream.
|
|
|
|
Signed-off-by: Lionel Orry <lionel.orry@gmail.com>
|
|
---
|
|
Makefile | 2 +-
|
|
tools/config_modules/Makefile | 2 +-
|
|
tools/filters/Makefile | 2 +-
|
|
tools/m2sh/Makefile | 2 +-
|
|
tools/procer/Makefile | 2 +-
|
|
5 files changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 6dce4a6..d48e05e 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1,4 +1,4 @@
|
|
-CFLAGS=-g -O2 -Wall -Wextra -Isrc -Isrc/polarssl/include -pthread -rdynamic -DNDEBUG $(OPTFLAGS) -D_FILE_OFFSET_BITS=64
|
|
+override CFLAGS += -g -O2 -Wall -Wextra -Isrc -Isrc/polarssl/include -pthread -rdynamic -DNDEBUG $(OPTFLAGS) -D_FILE_OFFSET_BITS=64
|
|
LIBS=-lzmq -ldl -lsqlite3 $(OPTLIBS)
|
|
PREFIX?=/usr/local
|
|
|
|
diff --git a/tools/config_modules/Makefile b/tools/config_modules/Makefile
|
|
index 398490c..53f2255 100644
|
|
--- a/tools/config_modules/Makefile
|
|
+++ b/tools/config_modules/Makefile
|
|
@@ -1,5 +1,5 @@
|
|
PREFIX?=/usr/local
|
|
-CFLAGS=-I../../src -I../../src/polarssl/include $(OPTFLAGS) -fPIC -shared -nostartfiles -L../../build
|
|
+override CFLAGS += -I../../src -I../../src/polarssl/include $(OPTFLAGS) -fPIC -shared -nostartfiles -L../../build
|
|
LDFLAGS=$(OPTLIBS)
|
|
|
|
MONGO_SRC = mongo-c-driver/src/bson.c \
|
|
diff --git a/tools/filters/Makefile b/tools/filters/Makefile
|
|
index f9f4556..6077b79 100644
|
|
--- a/tools/filters/Makefile
|
|
+++ b/tools/filters/Makefile
|
|
@@ -1,5 +1,5 @@
|
|
PREFIX?=/usr/local
|
|
-CFLAGS=-I../../src -I../../src/polarssl/include $(OPTFLAGS) -g -fPIC -shared -nostartfiles -L../../build
|
|
+ override CFLAGS += -I../../src -I../../src/polarssl/include $(OPTFLAGS) -g -fPIC -shared -nostartfiles -L../../build
|
|
LDFLAGS=$(OPTLIBS)
|
|
|
|
all: null.so
|
|
diff --git a/tools/m2sh/Makefile b/tools/m2sh/Makefile
|
|
index b50d8a0..ba378c5 100644
|
|
--- a/tools/m2sh/Makefile
|
|
+++ b/tools/m2sh/Makefile
|
|
@@ -1,4 +1,4 @@
|
|
-CFLAGS=-DNDEBUG -DNO_LINENOS -pthread -g -I../../src -Isrc -Wall $(OPTFLAGS)
|
|
+override CFLAGS += -DNDEBUG -DNO_LINENOS -pthread -g -I../../src -Isrc -Wall $(OPTFLAGS)
|
|
LIBS=-lzmq -lsqlite3 ../../build/libm2.a $(OPTLIBS)
|
|
|
|
PREFIX?=/usr/local
|
|
diff --git a/tools/procer/Makefile b/tools/procer/Makefile
|
|
index d0d7de0..629b2e9 100644
|
|
--- a/tools/procer/Makefile
|
|
+++ b/tools/procer/Makefile
|
|
@@ -1,4 +1,4 @@
|
|
-CFLAGS=-DNDEBUG -pthread -g -I../../src -Wall $(OPTFLAGS)
|
|
+override CFLAGS += -DNDEBUG -pthread -g -I../../src -Wall $(OPTFLAGS)
|
|
PREFIX?=/usr/local
|
|
LIBS?=-lzmq
|
|
SOURCES=$(wildcard *.c)
|
|
--
|
|
1.8.1.4
|
|
|