ccc1cc9490
Import a one-line patch that removes the hardcoded usage of shared_library() from the Meson build system in favor of plain library(), which allows to choose a static build as well. Fixes: - http://autobuild.buildroot.net/results/7263324435d6d25d7da98824d4313e7c45071de8 - http://autobuild.buildroot.net/results/9e6c807455b5a4e8986e8388426d98024119aa9c Signed-off-by: Adrian Perez de Castro <aperez@igalia.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
35 lines
1.0 KiB
Diff
35 lines
1.0 KiB
Diff
From 003c2e84d95357bbbef72fb395ef85f1650097a3 Mon Sep 17 00:00:00 2001
|
|
From: Adrian Perez de Castro <aperez@igalia.com>
|
|
Date: Fri, 23 Sep 2022 14:35:51 +0300
|
|
Subject: [PATCH] Meson: Un-hardcode building a shared library
|
|
|
|
Use library() instead of shared_library() to allow specifying which kind
|
|
of library to build with "meson setup --default-library ..."
|
|
|
|
This allows more easily incorporating libmanette in an application e.g.
|
|
as a Meson subproject which gets built into a program as a static
|
|
library.
|
|
|
|
Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
|
|
[Upstream status: https://gitlab.gnome.org/GNOME/libmanette/-/merge_requests/84]
|
|
---
|
|
src/meson.build | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/meson.build b/src/meson.build
|
|
index c140cac..b71d090 100644
|
|
--- a/src/meson.build
|
|
+++ b/src/meson.build
|
|
@@ -63,7 +63,7 @@ if gudev.found()
|
|
libmanette_deps += [ gudev ]
|
|
endif
|
|
|
|
-libmanette_lib = shared_library(
|
|
+libmanette_lib = library(
|
|
libmanette_module,
|
|
libmanette_sources,
|
|
c_args: libmanette_c_args,
|
|
--
|
|
2.37.3
|
|
|