e65cf4c4ff
This series includes two patches to fix static linking with libshout. The first patch fixes two typos resulting in an uninterpretable library propagation and is mainly needed for the follow-up patch. The second patch makes sure that `@SHOUT_REQUIRES@` and therefore `Requires.private` includes ssl as `Requires.private` defines a list of private packages required by this package but not exposed to applications. Note that autoreconf is enabled as the first patch touches configure.ac. Fixes: http://autobuild.buildroot.net/results/b82/b82408fccbf816575125dcc1a1de7260f66f62e8/ http://autobuild.buildroot.net/results/360/3605750023267e4cd35d98451bd283f9e70a6106/ http://autobuild.buildroot.net/results/03b/03b98b313dd6ed2909607cdc0c4f6fb87be3ccfe/ http://autobuild.buildroot.net/results/70b/70ba47e04d1fc0d2379bf1ac7aab4c52d6193001/ [Peter: fix libssl .pc reference, fix typo] Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
46 lines
1.4 KiB
Diff
46 lines
1.4 KiB
Diff
From d96a3cafeebeb80b4796bacbe0e6da0bbd3ee48e Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?J=C3=B6rg=20Krause?= <joerg.krause@embedded.rocks>
|
|
Date: Sun, 28 Aug 2016 00:39:55 +0200
|
|
Subject: [PATCH 1/2] Fix {THEORA,SPEEX}_LDFLAGS typo
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Needed to properly link against libshout, otherwise the build fails with:
|
|
|
|
error: LDFLAGS: No such file or directory
|
|
|
|
Upstream status: pending
|
|
https://github.com/xiph/Icecast-libshout/pull/4
|
|
|
|
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
|
|
---
|
|
configure.ac | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 87a7f55..85f18ad 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -134,7 +134,7 @@ PKG_CHECK_MODULES(THEORA, theora, [
|
|
])
|
|
fi
|
|
XIPH_VAR_APPEND([XIPH_CPPFLAGS],[$THEORA_CFLAGS])
|
|
-XIPH_VAR_PREPEND([XIPH_LIBS],[$THEORA LDFLAGS $THEORA_LIBS])
|
|
+XIPH_VAR_PREPEND([XIPH_LIBS],[$THEORA_LDFLAGS $THEORA_LIBS])
|
|
AM_CONDITIONAL([HAVE_THEORA], [test -n "$THEORA_LIBS"])
|
|
if test -n "$THEORA_LIBS"
|
|
then
|
|
@@ -153,7 +153,7 @@ PKG_CHECK_MODULES(SPEEX, speex, [
|
|
])
|
|
fi
|
|
XIPH_VAR_APPEND([XIPH_CPPFLAGS],[$SPEEX_CFLAGS])
|
|
-XIPH_VAR_PREPEND([XIPH_LIBS],[$SPEEX LDFLAGS $SPEEX_LIBS])
|
|
+XIPH_VAR_PREPEND([XIPH_LIBS],[$SPEEX_LDFLAGS $SPEEX_LIBS])
|
|
AM_CONDITIONAL([HAVE_SPEEX], [test -n "$SPEEX_LIBS"])
|
|
if test -n "$SPEEX_LIBS"
|
|
then
|
|
--
|
|
2.9.3
|
|
|