5cb061e1a7
git fails to build with NLS enabled because of weak check
for gettext in configure.ac. The AC_CHECK_LIB(c, gettext ...)
is used to set LIBC_CONTAINS_LIBINTL variable. If the variable
is set then '-libs' is not passed to the linker, but this variable
is set to 'Yes' even libc implementation does not provide libintl
support, the AC_CHECK passes because gcc has gettext builtin.
So use instead AC_LINK_IFELSE with included libintl.h because it
makes gettext to unfold as libintl_gettext which causes AC_CHECK
to fail for cases when gettext is not provided by libc.
Tested by ./utils/test-pkg with NLS disabled/enabled.
Fixes:
http://autobuild.buildroot.net/results/091b790ca6f5b46d5d29211dc1cb3ff05b62a965
http://autobuild.buildroot.net/results/a69b58b35b270fdd2df9b076e7030bb594520197
http://autobuild.buildroot.net/results/f104c4e6ff41b1dd175f2d27f3b4ea7c9b61f7c5
http://autobuild.buildroot.net/results/ee12bdba398a139995de5f6f6718be6a493541d9
http://autobuild.buildroot.net/results/74fa6b2bfbb1301e35c9dd1bbc04856c1cbf25f2
Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
(cherry picked from commit cb3a0177ef
)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
50 lines
1.4 KiB
Diff
50 lines
1.4 KiB
Diff
From 01da08fd60a0bdb2994f85f943dba148d9321d4d Mon Sep 17 00:00:00 2001
|
|
From: Vadim Kochan <vadim4j@gmail.com>
|
|
Date: Wed, 17 Apr 2019 01:25:40 +0300
|
|
Subject: [PATCH 1/1] configure.ac: Properly check for libintl
|
|
|
|
Some libc implementations like uclibc or musl provides
|
|
gettext stubs via libintl library but this case is not checked
|
|
by AC_CHECK_LIBRARY(c, gettext ...) because gcc has gettext as builtin
|
|
which passess the check.
|
|
|
|
So check it with included libintl.h where gettext may unfold into
|
|
libintl_gettext which will cause check to fail if libintl_gettext are
|
|
needed to be linked with -lintl.
|
|
|
|
Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
|
|
---
|
|
configure.ac | 16 +++++++++++++---
|
|
1 file changed, 13 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 7f84151..0b8e25f 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -762,9 +762,19 @@ AC_CHECK_LIB([c], [basename],
|
|
GIT_CONF_SUBST([NEEDS_LIBGEN])
|
|
test -n "$NEEDS_LIBGEN" && LIBS="$LIBS -lgen"
|
|
|
|
-AC_CHECK_LIB([c], [gettext],
|
|
-[LIBC_CONTAINS_LIBINTL=YesPlease],
|
|
-[LIBC_CONTAINS_LIBINTL=])
|
|
+AC_DEFUN([LIBINTL_SRC], [
|
|
+AC_LANG_PROGRAM([[
|
|
+#include <libintl.h>
|
|
+]],[[
|
|
+char *msg = gettext("test");
|
|
+]])])
|
|
+
|
|
+AC_MSG_CHECKING([if libc contains libintl])
|
|
+AC_LINK_IFELSE([LIBINTL_SRC],
|
|
+ [AC_MSG_RESULT([yes])
|
|
+ LIBC_CONTAINS_LIBINTL=YesPlease],
|
|
+ [AC_MSG_RESULT([no])
|
|
+ LIBC_CONTAINS_LIBINTL=])
|
|
GIT_CONF_SUBST([LIBC_CONTAINS_LIBINTL])
|
|
|
|
#
|
|
--
|
|
2.14.1
|
|
|