5502943b3b
Keep the same patch as for gcc 9.x fixing a parallel build issue:
58ecbbc3ef
.
Keep libzstd support disabled for now, it could be used in the future
for LTO bytecode compression.
https://gcc.gnu.org/gcc-10/changes.html
https://gcc.gnu.org/gcc-10/porting_to.html
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
80 lines
3.0 KiB
Diff
80 lines
3.0 KiB
Diff
From f05b73275515c4a1a70e28e06229bf682ac74385 Mon Sep 17 00:00:00 2001
|
||
From: Romain Naour <romain.naour@gmail.com>
|
||
Date: Thu, 21 May 2020 15:58:02 +0200
|
||
Subject: [PATCH] gcc/Makefile.in: move SELFTEST_DEPS before including language
|
||
makefile fragments
|
||
|
||
As reported by several Buildroot users [1][2][3], the gcc build
|
||
may fail while running selftests makefile target.
|
||
|
||
The problem only occurs when ccache is used with gcc 9 and 10,
|
||
probably due to a race condition.
|
||
|
||
While debuging with "make -p" we can notice that s-selftest-c target
|
||
contain only "cc1" as dependency instead of cc1 and SELFTEST_DEPS [4].
|
||
|
||
s-selftest-c: cc1
|
||
|
||
While the build is failing, the s-selftest-c dependencies recipe is
|
||
still running and reported as a bug by make.
|
||
|
||
"Dependencies recipe running (THIS IS A BUG)."
|
||
|
||
A change [5] in gcc 9 seems to introduce the problem since we can't
|
||
reproduce this problem with gcc 8.
|
||
|
||
As suggested by Yann E. MORIN [6], move SELFTEST_DEPS before
|
||
including language makefile fragments.
|
||
|
||
With the fix applied, the s-seltest-c dependency contains
|
||
SELFTEST_DEPS value.
|
||
|
||
s-selftest-c: cc1 xgcc specs stmp-int-hdrs ../../gcc/testsuite/selftests
|
||
|
||
[1] http://lists.busybox.net/pipermail/buildroot/2020-May/282171.html
|
||
[2] http://lists.busybox.net/pipermail/buildroot/2020-May/282766.html
|
||
[3] https://github.com/cirosantilli/linux-kernel-module-cheat/issues/108
|
||
[4] https://gcc.gnu.org/git/?p=gcc.git;a=blob;f=gcc/c/Make-lang.in;h=bfae6fd2549c4f728816cd355fa9739dcc08fcde;hb=033eb5671769a4c681a44aad08a454e667e08502#l120
|
||
[5] https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=033eb5671769a4c681a44aad08a454e667e08502
|
||
[6] http://lists.busybox.net/pipermail/buildroot/2020-May/283213.html
|
||
|
||
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||
Cc: Ben Dakin-Norris <ben.dakin-norris@navtechradar.com>
|
||
Cc: Maxim Kochetkov <fido_max@inbox.ru>
|
||
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
|
||
Cc: David Malcolm <dmalcolm@gcc.gnu.org>
|
||
---
|
||
This patch should be backported to gcc 10 and gcc 9.
|
||
---
|
||
gcc/Makefile.in | 6 ++++--
|
||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||
|
||
diff --git a/gcc/Makefile.in b/gcc/Makefile.in
|
||
index 543b477ff18..c8611e35c70 100644
|
||
--- a/gcc/Makefile.in
|
||
+++ b/gcc/Makefile.in
|
||
@@ -1725,6 +1725,10 @@ $(FULL_DRIVER_NAME): ./xgcc
|
||
rm -f $@
|
||
$(LN_S) $< $@
|
||
|
||
+# SELFTEST_DEPS need to be set before including language makefile fragments.
|
||
+# Otherwise $(SELFTEST_DEPS) is empty when used from various <LANG>/Make-lang.in.
|
||
+SELFTEST_DEPS = $(GCC_PASSES) stmp-int-hdrs $(srcdir)/testsuite/selftests
|
||
+
|
||
#
|
||
# Language makefile fragments.
|
||
|
||
@@ -2001,8 +2005,6 @@ DEVNULL=$(if $(findstring mingw,$(build)),nul,/dev/null)
|
||
SELFTEST_FLAGS = -nostdinc $(DEVNULL) -S -o $(DEVNULL) \
|
||
-fself-test=$(srcdir)/testsuite/selftests
|
||
|
||
-SELFTEST_DEPS = $(GCC_PASSES) stmp-int-hdrs $(srcdir)/testsuite/selftests
|
||
-
|
||
# Run the selftests during the build once we have a driver and the frontend,
|
||
# so that self-test failures are caught as early as possible.
|
||
# Use "s-selftest-FE" to ensure that we only run the selftests if the
|
||
--
|
||
2.25.4
|
||
|