4b36d50b99
Switch to the new upstream site on kernel.org, and to a .tar.xz tarball. The patches are simply refreshed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
39 lines
1.2 KiB
Diff
39 lines
1.2 KiB
Diff
From b981adb6769f6b7d80f6c98627391398a007a25b Mon Sep 17 00:00:00 2001
|
|
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Date: Tue, 15 Dec 2015 20:51:35 -0300
|
|
Subject: [PATCH] xfsprogs: don't use CFLAGS with BUILD_CC
|
|
|
|
When cross-compiling CFLAGS might not be suitable for the host
|
|
(BUILD_CC) compiler since it might contain arch-specific options.
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
---
|
|
libxfs/Makefile | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libxfs/Makefile b/libxfs/Makefile
|
|
index e021625..ad76a04 100644
|
|
--- a/libxfs/Makefile
|
|
+++ b/libxfs/Makefile
|
|
@@ -118,7 +118,7 @@ default: ltdepend $(LTLIBRARY)
|
|
|
|
crc32table.h: gen_crc32table.c
|
|
@echo " [CC] gen_crc32table"
|
|
- $(Q) $(BUILD_CC) $(CFLAGS) -o gen_crc32table $<
|
|
+ $(Q) $(BUILD_CC) -o gen_crc32table $<
|
|
@echo " [GENERATE] $@"
|
|
$(Q) ./gen_crc32table > crc32table.h
|
|
|
|
@@ -129,7 +129,7 @@ crc32table.h: gen_crc32table.c
|
|
# disk.
|
|
crc32selftest: gen_crc32table.c crc32table.h crc32.c
|
|
@echo " [TEST] CRC32"
|
|
- $(Q) $(BUILD_CC) $(CFLAGS) -D CRC32_SELFTEST=1 crc32.c -o $@
|
|
+ $(Q) $(BUILD_CC) -D CRC32_SELFTEST=1 crc32.c -o $@
|
|
$(Q) ./$@
|
|
|
|
# set up include/xfs header directory
|
|
--
|
|
2.7.4
|
|
|