d1d735a148
In buildroot, libtirpc is patched to remove authdes_create functions.
As a result, compilation of tests that use these functions, fails.
A previous fix was implemented in commit
8f1c4c49a2
, but simply disabled linking with
libtirpc entirely. This broke usage of ltp-testsuite on targets where the
toolchain does not have RPC support and libtirpc is mandatory.
Instead, disable only the problematic tests, leaving ltp-testsuite usable
with libtirpc.
Cc: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
rpc-tirpc: disable tirpc_auth_authdes_seccreate tests
|
|
|
|
Due to Buildroot patch 0007-Disable-DES-authentification-support.patch on
|
|
libtirpc, this library is built without method authdes_create. Any code
|
|
that uses this library, like the rpc-tirpc testsuite, thus fails to link.
|
|
|
|
In the context of Buildroot, instead of disabling ltp-testsuite entirely,
|
|
just disable the problematic tests.
|
|
|
|
Upstream-status: not applicable
|
|
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
|
|
---
|
|
testcases/network/rpc/rpc-tirpc/tests_pack/rpc_suite/tirpc/Makefile | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
diff --git a/testcases/network/rpc/rpc-tirpc/tests_pack/rpc_suite/tirpc/Makefile b/testcases/network/rpc/rpc-tirpc/tests_pack/rpc_suite/tirpc/Makefile
|
|
index 45bc8a6..6c4089e 100644
|
|
--- a/testcases/network/rpc/rpc-tirpc/tests_pack/rpc_suite/tirpc/Makefile
|
|
+++ b/testcases/network/rpc/rpc-tirpc/tests_pack/rpc_suite/tirpc/Makefile
|
|
@@ -19,4 +19,7 @@
|
|
top_srcdir ?= ../../../../../../..
|
|
|
|
include $(top_srcdir)/include/mk/env_pre.mk
|
|
+
|
|
+FILTER_OUT_DIRS += tirpc_auth_authdes_seccreate
|
|
+
|
|
include $(top_srcdir)/include/mk/generic_trunk_target.mk
|
|
--
|
|
1.9.5
|
|
|