cd18114d65
- added libsquish as new dependencyf73653d62b (diff-3b3a6ec97232deb43dc14319a73872c1R2207)
- updated build procedure for host version of texturepacker - removed SDL dependencies http://kodi.wiki/view/Kodi_v15_%28Isengard%29_changelog#Linux_Specific "Removed dependencies of SDL (Simple DirectMedia Layer) for everything but hardware abstraction for input devices" - added mips support:5d1746ad5b
[Thomas: - don't do a manual fixup of kodi-config.cmake, and instead patch it to use CMAKE_FIND_ROOT_PATH. This will also avoid having to pass -DCMAKE_MODULE_PATH to all Kodi add-ons .mk files.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
39 lines
1.5 KiB
Diff
39 lines
1.5 KiB
Diff
From 6604cce38fed748e98d3bd2bf9d0f368d67eeb3c Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 29 Jul 2015 23:13:33 +0200
|
|
Subject: [PATCH] kodi-config.cmake: use CMAKE_FIND_ROOT_PATH to fix
|
|
cross-compilation
|
|
|
|
When cross-compiling, the location at build time of the libraries is
|
|
not the same as the one at run-time. The CMAKE_FIND_ROOT_PATH variable
|
|
is here to handle this difference, so use it in kodi-config.cmake.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
project/cmake/kodi-config.cmake.in | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/project/cmake/kodi-config.cmake.in b/project/cmake/kodi-config.cmake.in
|
|
index 76626ec..ffb8e1d 100644
|
|
--- a/project/cmake/kodi-config.cmake.in
|
|
+++ b/project/cmake/kodi-config.cmake.in
|
|
@@ -4,12 +4,12 @@ SET(APP_NAME_UC @APP_NAME_UC@)
|
|
SET(APP_VERSION_MAJOR @APP_VERSION_MAJOR@)
|
|
SET(APP_VERSION_MINOR @APP_VERSION_MINOR@)
|
|
SET(@APP_NAME_UC@_PREFIX @APP_PREFIX@)
|
|
-SET(@APP_NAME_UC@_INCLUDE_DIR @APP_INCLUDE_DIR@)
|
|
-SET(@APP_NAME_UC@_LIB_DIR @APP_LIB_DIR@)
|
|
+SET(@APP_NAME_UC@_INCLUDE_DIR ${CMAKE_FIND_ROOT_PATH}/@APP_INCLUDE_DIR@)
|
|
+SET(@APP_NAME_UC@_LIB_DIR ${CMAKE_FIND_ROOT_PATH}/@APP_LIB_DIR@)
|
|
IF(NOT WIN32)
|
|
SET(CMAKE_CXX_FLAGS "$ENV{CXXFLAGS} @CXX11_SWITCH@")
|
|
ENDIF()
|
|
-LIST(APPEND CMAKE_MODULE_PATH @APP_LIB_DIR@)
|
|
+LIST(APPEND CMAKE_MODULE_PATH ${CMAKE_FIND_ROOT_PATH}/@APP_LIB_DIR@)
|
|
ADD_DEFINITIONS(@ARCH_DEFINES@ -DBUILD_KODI_ADDON)
|
|
|
|
include(addon-helpers)
|
|
--
|
|
2.5.0
|
|
|