4102db0f7a
Changes include: - Change the package type to meson, as autoconf is no longer supported. - Add 0002-add-option-to-build-tests.patch Upstream won't build tests when cross-compiling. However; this means still building the tests during a host build. Building the tests causes build failures on older distributions such as CentOS 6 and Debian 7 because of the command `objcopy --add-symbol` is used when building the test "test_resources2," which is not available with the older version of objcopy provided by the distributions. - Add 0003-remove-cpp-requirement.patch: C++ is not needed when just compiling. The inclusion of C++ in meson.build is to ensure libglib doesn't accidentally use C++ reserved keywords in public headers. Because tests aren't being compiled, there is no need for C++ as a requirement. (https://gitlab.gnome.org/GNOME/glib/issues/1748) - Add 0004-Add-Wno-format-nonliteral-to-compiler-arguments.patch: This prevents a false error when compiling against older gcc versions. (https://gitlab.gnome.org/GNOME/glib/issues/1744) - Remove 0004-Do-not-hardcode-python-path-into-various-tools.patch: The switch to meson makes this obsolete. - Remove LIBGLIB2_AUTORECONF = YES from libglib2.mk: Now that libglib2 is a meson package, there is no need for AUTORECONF. - Remove LIBGLIB2_INSTALL_STAGING_OPTS from libglib2.mk: Meson resolves these correctly. - Add LIBGLIB2_REMOVE_BINDIR_PREFIX_FROM_PC_FILE in libglib2.mk: Newer versions of libglib2 prefix glib-genmarshal, gobject-query, and glib-mkenums with ${bindir}. Unfortunately, this will resolve to the host systems /bin/ directory, which will cause compilation issues if the host does not have these programs. By removing the ${bindir}/ prefix, these programs are resolved in PATH instead. Signed-off-by: Adam Duskett <Aduskett@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
29 lines
964 B
Diff
29 lines
964 B
Diff
From 9e0f11a4981737f98bac93a22b6f2ff1a3887b63 Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <Aduskett@gmail.com>
|
|
Date: Tue, 9 Apr 2019 13:03:51 -0400
|
|
Subject: [PATCH] Add '-Wno-format-nonliteral' to compiler arguments.
|
|
|
|
This warning is a false positive on older versions of gcc.
|
|
See https://gitlab.gnome.org/GNOME/glib/issues/1744 for more details.
|
|
|
|
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
|
|
---
|
|
meson.build | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 3c615b7..7cae4e8 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -357,6 +357,7 @@ if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
|
|
'-Wno-cast-function-type',
|
|
+ '-Wno-format-nonliteral',
|
|
# Due to function casts through (void*) we cannot support -Wpedantic:
|
|
# https://wiki.gnome.org/Projects/GLib/CompilerRequirements#Function_pointer_conversions.
|
|
'-Wno-pedantic',
|
|
'-Werror=declaration-after-statement',
|
|
'-Werror=format=2',
|
|
--
|
|
2.20.1
|
|
|