dd5dbe627f
This package provides BLAS and LAPACK libraries. Though it is common to find implementation of these two libraries in Fortran, this package provides a C-implementation for both, because: - Fortran support has been deprecated in Buildroot since the 2013.11 release; - most of the external toolchains do not provide a Fortran compiler. Often BLAS build-systems build some test programs and run them to generate some source files or adjust some build optimizations, naively assuming they are building the library for the build-machine. This does not play well when cross-compiling. This implementation has this defect too, by building and running a tool generating a header. However, the build-system allows to pass an empty header. So, we have to patch the CMake to build the generator (but never install it) and correctly support building with and without this header provided by the user. Also, some CMake patches are needed to fix the build and install rules. [Peter: needs largefile, fix _LICENSE_FILES, tweak patch desc] Signed-off-by: Samuel Martin <s.martin49@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
24 lines
766 B
Diff
24 lines
766 B
Diff
From 675111e8ffc179276a7e4950fe4a4eda4d38a703 Mon Sep 17 00:00:00 2001
|
|
From: Samuel Martin <s.martin49@gmail.com>
|
|
Date: Sat, 11 Jan 2014 21:48:32 +0100
|
|
Subject: [PATCH 4/6] cmake: blas: add library and header install rules
|
|
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
---
|
|
BLAS/SRC/CMakeLists.txt | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/BLAS/SRC/CMakeLists.txt b/BLAS/SRC/CMakeLists.txt
|
|
index d1caff8..a5de5a1 100644
|
|
--- a/BLAS/SRC/CMakeLists.txt
|
|
+++ b/BLAS/SRC/CMakeLists.txt
|
|
@@ -141,3 +141,5 @@ if(UNIX)
|
|
target_link_libraries(blas m)
|
|
endif()
|
|
target_link_libraries(blas f2c)
|
|
+install(TARGETS blas LIBRARY DESTINATION lib ARCHIVE DESTINATION lib)
|
|
+install(FILES "${CLAPACK_SOURCE_DIR}/INCLUDE/blaswrap.h" DESTINATION include)
|
|
--
|
|
1.8.5.3
|
|
|