9972408a94
Remove upstream or unneeded patches. Renumber and refresh the doc disable patch. Add a different version of the lanplus disable fix (sent upstream) that integrates with upstream change in this area. Cc: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
39 lines
993 B
Diff
39 lines
993 B
Diff
From: Baruch Siach <baruch@tkos.co.il>
|
|
Date: Tue, 27 Oct 2015 14:23:44 +0200
|
|
Subject: [PATCH] lib/Makefile.am: fix lanplus disable
|
|
|
|
Protect the install target as well when lanplus is disabled. Fixes the
|
|
following installation failure when openssl is missing:
|
|
|
|
In file included from lanplus.c:78:0:
|
|
./inc/ipmitool/ipmi.h:51:25: fatal error: openssl/evp.h: No such file or directory
|
|
|
|
Patch status: sent upstream
|
|
(http://sourceforge.net/p/ipmiutil/mailman/message/34572580/)
|
|
|
|
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
|
---
|
|
lib/Makefile.am | 6 ++++--
|
|
1 file changed, 4 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/lib/Makefile.am b/lib/Makefile.am
|
|
index 805a218ab7eb..939594cfd3e5 100644
|
|
--- a/lib/Makefile.am
|
|
+++ b/lib/Makefile.am
|
|
@@ -51,8 +51,10 @@ distclean:
|
|
cd lanplus; make distclean
|
|
|
|
install:
|
|
- $(MKDIR) ${datato}
|
|
- cd lanplus; make install
|
|
+ if [ "$(PLUSFLAGS)" = "-DHAVE_LANPLUS" ]; then \
|
|
+ $(MKDIR) ${datato} ; \
|
|
+ cd lanplus; make install ; \
|
|
+ fi
|
|
|
|
check:
|
|
|
|
--
|
|
2.6.1
|
|
|