469c11c516
Other changes: - Remove BR2_PACKAGE_PHP_EXT_JSON as the json extension is now an integral part of PHP and is no longer optional. Due to this, it is not added to Config.in.legacy. - Move BR2_PACKAGE_PHP_EXT_XMLRPC to Config.in.legacy as the extension has been removed. See https://wiki.php.net/rfc/unbundle_xmlprc for an explination. - Add a new patch that allows for opcache to cross-compile with PHP8. - Explicitly disable opcache-jit when opcache is enabled, as the JIT fails to cross-compile. - --enable-maintainer-zts is now --enable-zts Signed-off-by: Adam Duskett <aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
44 lines
1.5 KiB
Diff
44 lines
1.5 KiB
Diff
From 5ba6355e489f647c88ca48afbc75965468193181 Mon Sep 17 00:00:00 2001
|
|
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Date: Tue, 9 Aug 2016 11:51:53 +0200
|
|
Subject: [PATCH] configure: disable the 'phar' tool
|
|
|
|
Disable the 'phar' command-line tool build/installation since it requires
|
|
php to run and pack up phar itself in phar format. This would require
|
|
a host-php instance and really probably nobody needs the phar tool
|
|
on the target.
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
[Gustavo: update for autoreconf/configure.in]
|
|
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
|
[Aduskett: update for 8.0.7]
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
[Bernd: rebased for 7.4.10 & 7.4.13]
|
|
---
|
|
configure.ac | 9 ++-------
|
|
1 file changed, 2 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 0dfab302..6026fb66 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1423,13 +1423,8 @@ CFLAGS_CLEAN="$CFLAGS \$(PROF_FLAGS)"
|
|
CFLAGS="\$(CFLAGS_CLEAN) $standard_libtool_flag"
|
|
CXXFLAGS="$CXXFLAGS $standard_libtool_flag \$(PROF_FLAGS)"
|
|
|
|
-if test "$PHP_PHAR" != "no" && test "$PHP_CLI" != "no"; then
|
|
- pharcmd=pharcmd
|
|
- pharcmd_install=install-pharcmd
|
|
-else
|
|
- pharcmd=
|
|
- pharcmd_install=
|
|
-fi;
|
|
+pharcmd=
|
|
+pharcmd_install=
|
|
|
|
all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_BINARIES) $pharcmd"
|
|
install_targets="$install_sapi $install_modules $install_binaries install-build install-headers install-programs $install_pear $pharcmd_install"
|
|
--
|
|
2.14.3
|
|
|