0fb1b80532
VLC uses Git as its version control system, so it makes sense to use Git formatted patches. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
32 lines
1.2 KiB
Diff
32 lines
1.2 KiB
Diff
From 418e5e692a1f975d41eab3bd15895b2ba0a7eee1 Mon Sep 17 00:00:00 2001
|
|
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
Date: Tue, 1 May 2018 22:30:09 +0200
|
|
Subject: [PATCH] Don't hardcode the name of the vorbis and ogg libraries
|
|
|
|
Fixes linking error with tremor due to wrong library name.
|
|
|
|
Downloaded from Gentoo package
|
|
https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-video/vlc/files/vlc-2.1.0-fix-libtremor-libs.patch?view=markup
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
modules/codec/Makefile.am | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/modules/codec/Makefile.am b/modules/codec/Makefile.am
|
|
index bc39a4facc..c5cd2fb7f9 100644
|
|
--- a/modules/codec/Makefile.am
|
|
+++ b/modules/codec/Makefile.am
|
|
@@ -234,7 +234,7 @@ codec_LTLIBRARIES += $(LTLIBtheora)
|
|
libtremor_plugin_la_SOURCES = codec/vorbis.c
|
|
libtremor_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) -DMODULE_NAME_IS_tremor
|
|
libtremor_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(codecdir)'
|
|
-libtremor_plugin_la_LIBADD = -lvorbisdec -logg
|
|
+libtremor_plugin_la_LIBADD = $(VORBIS_LIBS) $(OGG_LIBS)
|
|
EXTRA_LTLIBRARIES += libtremor_plugin.la
|
|
codec_LTLIBRARIES += $(LTLIBtremor)
|
|
|
|
--
|
|
2.14.3
|
|
|