kumquat-buildroot/package/s390-tools/0001-zipl-boot-disable-SSP.patch
Alexander Egorenkov 800541bb33 package/s390-tools: fix SSP build
Fixes:
 - http://autobuild.buildroot.net/results/f906ca8650a7a9ccca4a2ee359a807d08a7763b9

Signed-off-by: Alexander Egorenkov <egorenar@linux.ibm.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-10-24 22:55:09 +02:00

29 lines
1018 B
Diff

From 5ba78a11cbf2cab793e4214170a9ab540687e3c8 Mon Sep 17 00:00:00 2001
From: Alexander Egorenkov <egorenar@linux.ibm.com>
Date: Tue, 20 Oct 2020 12:50:58 +0200
Subject: [PATCH] zipl/boot: disable SSP
SSP cannot work with boot loaders because it requires libc.
Signed-off-by: Alexander Egorenkov <egorenar@linux.ibm.com>
---
zipl/boot/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/zipl/boot/Makefile b/zipl/boot/Makefile
index 359189e5..a2e5f190 100644
--- a/zipl/boot/Makefile
+++ b/zipl/boot/Makefile
@@ -7,7 +7,7 @@ INCLUDE_PARMS := $(addprefix -I,$(INCLUDE_PATHS))
ALL_CFLAGS = $(NO_PIE_CFLAGS) -Os -g $(INCLUDE_PARMS) \
-DS390_TOOLS_RELEASE=$(S390_TOOLS_RELEASE) \
-fno-builtin -ffreestanding -fno-asynchronous-unwind-tables \
- -fno-delete-null-pointer-checks \
+ -fno-delete-null-pointer-checks -fno-stack-protector \
-fexec-charset=IBM1047 -m64 -mpacked-stack \
-mstack-size=4096 -mstack-guard=128 -msoft-float \
-W -Wall -Wformat-security
--
2.26.2