c2a39ba528
https://sourceware.org/ml/gdb-announce/2018/msg00001.html gdb 8.1 has a new optional dependency on mpfr, which according to the NEWS file: GDB now uses the GNU MPFR library, if available, to emulate target floating-point arithmetic during expression evaluation when the target uses different floating-point formats than the host. At least version 3.1 of GNU MPFR is required. So for the target gdb, this is unnecessary, and therefore we forcefully disable mpfr support by passing --without-mpfr. For the host gdb, it would potentially be useful, but since it's a new feature that isn't essential, we for now keep it disabled as well. An option may be added later if needed. To avoid gnulib issues with uClibc/musl, we need to pass additional configure/make variables, like is done in OpenEmbedded [1]. [1] http://git.openembedded.org/openembedded-core/tree/meta/recipes-devtools/gdb/gdb_8.1.bb?id=02664a8dcd1ebb6cd77248e1b97a78390ea06033#n9 We re-add the same patches as the ones present for gdb 8.0.1, except 0004-nat-linux-ptrace.c-add-missing-gdb_byte-cast.patch, which was merged upstream. Signed-off-by: Romain Naour <romain.naour@gmail.com> [Thomas: change mpfr handling.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
41 lines
1.1 KiB
Diff
41 lines
1.1 KiB
Diff
From 12a0b8d81e1fda6ba98abdce8d6f09f9555ebcf5 Mon Sep 17 00:00:00 2001
|
|
From: Andre McCurdy <amccurdy@gmail.com>
|
|
Date: Sat, 30 Apr 2016 15:29:06 -0700
|
|
Subject: [PATCH] use <asm/sgidefs.h>
|
|
|
|
Build fix for MIPS with musl libc
|
|
|
|
The MIPS specific header <sgidefs.h> is provided by glibc and uclibc
|
|
but not by musl. Regardless of the libc, the kernel headers provide
|
|
<asm/sgidefs.h> which provides the same definitions, so use that
|
|
instead.
|
|
|
|
Upstream-Status: Pending
|
|
|
|
[Vincent:
|
|
Taken from: https://sourceware.org/bugzilla/show_bug.cgi?id=21070]
|
|
|
|
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
|
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
---
|
|
gdb/mips-linux-nat.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/gdb/mips-linux-nat.c b/gdb/mips-linux-nat.c
|
|
index f2df1b9907..d24664cb56 100644
|
|
--- a/gdb/mips-linux-nat.c
|
|
+++ b/gdb/mips-linux-nat.c
|
|
@@ -31,7 +31,7 @@
|
|
#include "gdb_proc_service.h"
|
|
#include "gregset.h"
|
|
|
|
-#include <sgidefs.h>
|
|
+#include <asm/sgidefs.h>
|
|
#include "nat/gdb_ptrace.h"
|
|
#include <asm/ptrace.h>
|
|
#include "inf-ptrace.h"
|
|
--
|
|
2.13.1
|
|
|