01d3360eb6
Changes include: - Rename 0002-add-option-to-build-tests.patch to 0002-allow-explicit-disabling-of-tests.patch to work with 2.62.3. Upstream now has an option called "installed_tests," which can be used to prevent the unit tests from being built. However, the check only works for cross-compiling and not host builds, which would mean that the tests still build when compiling the host variant. This conditional causes an error on older systems such as Debian8 or Centos7 because the command `objcopy --add-symbol` is used when building the test "test_resources2," which is not available with the older version of objcopy provided by those distributions. Removing the conditionals and checking for just the installed_tests_enabled option allows for a much simpler patch. - Change -Dtests=false to -Dinstalled_tests=false in libglib2.mk as per the above comment. br-arm-full [1/6]: OK br-arm-cortex-a9-glibc [2/6]: OK br-arm-cortex-m4-full [3/6]: SKIPPED br-x86-64-musl [4/6]: OK br-arm-full-static [5/6]: OK sourcery-arm [6/6]: OK Signed-off-by: Adam Duskett <Aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
29 lines
964 B
Diff
29 lines
964 B
Diff
From 9e0f11a4981737f98bac93a22b6f2ff1a3887b63 Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <Aduskett@gmail.com>
|
|
Date: Tue, 9 Apr 2019 13:03:51 -0400
|
|
Subject: [PATCH] Add '-Wno-format-nonliteral' to compiler arguments.
|
|
|
|
This warning is a false positive on older versions of gcc.
|
|
See https://gitlab.gnome.org/GNOME/glib/issues/1744 for more details.
|
|
|
|
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
|
|
---
|
|
meson.build | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 3c615b7..7cae4e8 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -372,6 +372,7 @@ if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
|
|
'-Wno-cast-function-type',
|
|
+ '-Wno-format-nonliteral',
|
|
# Due to function casts through (void*) we cannot support -Wpedantic:
|
|
# https://wiki.gnome.org/Projects/GLib/CompilerRequirements#Function_pointer_conversions.
|
|
'-Wno-pedantic',
|
|
'-Werror=declaration-after-statement',
|
|
'-Werror=format=2',
|
|
--
|
|
2.20.1
|
|
|