298cd8eaa2
Autogenerated from rename-patch.py (http://patchwork.ozlabs.org/patch/403345) Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
45 lines
1.8 KiB
Diff
45 lines
1.8 KiB
Diff
Do not pass -D_REENTRANT
|
|
|
|
This flag is not needed to build this library, and prevents to build
|
|
it with toolchains that don't have thread support.
|
|
|
|
Since the Makefile.in change is a one-liner, we also do it in the
|
|
patch to avoid having to autoreconfigure the package.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/Makefile.am.inc
|
|
===================================================================
|
|
--- a/Makefile.am.inc
|
|
+++ b/Makefile.am.inc
|
|
@@ -1,2 +1,2 @@
|
|
-AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
|
|
+AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE
|
|
|
|
Index: b/Makefile.in
|
|
===================================================================
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -274,7 +274,7 @@
|
|
top_build_prefix = @top_build_prefix@
|
|
top_builddir = @top_builddir@
|
|
top_srcdir = @top_srcdir@
|
|
-AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
|
|
+AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE
|
|
EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc json-c.vcproj
|
|
SUBDIRS = . tests
|
|
lib_LTLIBRARIES = libjson-c.la $(am__append_1)
|
|
Index: b/tests/Makefile.in
|
|
===================================================================
|
|
--- a/tests/Makefile.in
|
|
+++ b/tests/Makefile.in
|
|
@@ -228,7 +228,7 @@
|
|
top_build_prefix = @top_build_prefix@
|
|
top_builddir = @top_builddir@
|
|
top_srcdir = @top_srcdir@
|
|
-AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
|
|
+AM_CFLAGS = -Wall -Werror -Wextra -Wwrite-strings -Wno-unused-parameter -std=gnu99 -D_GNU_SOURCE
|
|
LIBJSON_LA = $(top_builddir)/libjson-c.la
|
|
test1_LDADD = $(LIBJSON_LA)
|
|
test1Formatted_LDADD = $(LIBJSON_LA)
|