kumquat-buildroot/package/freeswitch/0001-Fix-cross-compiling-libvpx.patch
Bernd Kuhls 5cf68c8f79 package/freeswitch: bump version to 1.10.2
Rebased patch 0001.

Release notes:
https://github.com/signalwire/freeswitch/releases/tag/v1.10.2

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-01-04 16:28:29 +01:00

30 lines
1.6 KiB
Diff

Fix cross-compiling libvpx
Freeswitch since version 1.6.7 only uses an in-tree-version of libvpx:
https://freeswitch.org/fisheye/changelog/freeswitch?cs=febe0f8dacea2d2a31902b3dc469be757f8c3c4d
It is not possible to use an external version of libvpx anymore.
Unfortunately the freeswitch build system has no support for cross-
compiling libvpx so we need to patch Makefile to pass CROSS from
package/freeswitch/freeswitch.mk and add target=generic-gnu as
configure parameter:
https://freeswitch.org/stash/projects/FS/repos/freeswitch/browse/libs/libvpx/README#110
And yes, autoreconf is also broken, so we patch Makefile.in instead
of Makefile.am.
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
diff -uNr freeswitch-1.6.7.org/Makefile.in freeswitch-1.6.7/Makefile.in
--- freeswitch-1.6.7.org/Makefile.in 2016-04-01 18:09:54.000000000 +0200
+++ freeswitch-1.6.7/Makefile.in 2016-04-22 20:11:37.938961730 +0200
@@ -4182,7 +4182,7 @@
cd libs/libzrtp && $(MAKE)
libs/libvpx/Makefile: libs/libvpx/.update
- cd libs/libvpx && CC="$(CC)" CXX="$(CXX)" CFLAGS="$(CFLAGS) $(VISIBILITY_FLAG)" CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" ./configure --enable-pic --disable-docs --disable-examples --disable-install-bins --disable-install-srcs --disable-unit-tests --size-limit=16384x16384
+ cd libs/libvpx && CROSS=$(CROSS) CC="$(CC)" CXX="$(CXX)" CFLAGS="$(CFLAGS) $(VISIBILITY_FLAG)" CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" ./configure --enable-pic --disable-docs --disable-examples --disable-install-bins --disable-install-srcs --disable-unit-tests --size-limit=16384x16384
libs/libvpx/libvpx.a: libs/libvpx/Makefile libs/libvpx/.update
@cd libs/libvpx && $(MAKE)