96d3d01796
The reason for combining these patches is because the old version of setools is not compatible iwth libsepol 2.7. If a user where to do a git pull on a patch that only updates libsepol or setools, the build would fail to compile. setools has been completely rewritten in python instead of C. The current version of setools includes a few programs that require python-qt5 or python-networkx to run, however the package does not check to see if these exist when compiling, and will install the scripts to the target directory even if they don't exist. In the case of python-networkx, this package is not available on Buildroot. The scripts that require them are: sedta and seinfoflow. In the case of python-qt5, qpol is the script that requires it. Some setools.mk notes to get the package to compile: - Convert the package .mk to use python-package instead of autotools-package. - setup.py hard codes base_lib_dirs to point to several host directories. To fix this, sed is used before compiling to point the base_lib_dirs to the staging directory. - setup.py also includes the "Werror" flag, however compilers before gcc6 cause a few autogenerated variables to not be initialized before use, causing the build to fail. To fix this, a patch is provided that removes the Werror flag. - Remove sedta and seinfoflow from the target system after install. These packages rely on the package python-networkx which is not available in buildroot. - Remove the installed apol package and the setoolsgui directory from the target directory if python-qt5 is not selected. Other changes: - Removed all patches, as they are not compatible with the new version of setools. - Add COPYING, COPYING.GPL, and COPYING.LGPL to setools.hash Signed-off-by: Adam Duskett <Adamduskett@outlook.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
55 lines
1.6 KiB
Diff
55 lines
1.6 KiB
Diff
From 2140db697c7f1da2a0a3f7bbcb14c1a0dade84e5 Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <Adamduskett@outlook.com>
|
|
Date: Mon, 9 Oct 2017 16:28:12 -0400
|
|
Subject: [PATCH] Add support for static-only build
|
|
|
|
Instead of unconditionally building shared libraries, this patch
|
|
improves the libsepol build system with a "STATIC" variable, which
|
|
when defined to some non-empty value, will disable the build of shared
|
|
libraries. It allows to support cases where the target architecture
|
|
does not have support for shared libraries.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Adam Duskett <Adamduskett@outlook.com>
|
|
---
|
|
src/Makefile | 13 ++++++++++---
|
|
1 file changed, 10 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/src/Makefile b/src/Makefile
|
|
index 819d261..040921d 100644
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -40,7 +40,12 @@ LDFLAGS += -undefined dynamic_lookup
|
|
LN=gln
|
|
endif
|
|
|
|
-all: $(LIBA) $(LIBSO) $(LIBPC)
|
|
+ALL_TARGETS = $(LIBA) $(LIBPC)
|
|
+ifeq ($(STATIC),)
|
|
+ALL_TARGETS += $(LIBSO)
|
|
+endif
|
|
+
|
|
+all: $(ALL_TARGETS)
|
|
|
|
|
|
$(LIBA): $(OBJS)
|
|
@@ -82,11 +87,13 @@ endif
|
|
install: all
|
|
test -d $(LIBDIR) || install -m 755 -d $(LIBDIR)
|
|
install -m 644 $(LIBA) $(LIBDIR)
|
|
- test -d $(SHLIBDIR) || install -m 755 -d $(SHLIBDIR)
|
|
- install -m 755 $(LIBSO) $(SHLIBDIR)
|
|
test -d $(LIBDIR)/pkgconfig || install -m 755 -d $(LIBDIR)/pkgconfig
|
|
install -m 644 $(LIBPC) $(LIBDIR)/pkgconfig
|
|
+ifeq ($(STATIC),)
|
|
+ test -d $(SHLIBDIR) || install -m 755 -d $(SHLIBDIR)
|
|
+ install -m 755 $(LIBSO) $(SHLIBDIR)
|
|
$(LN) -sf --relative $(SHLIBDIR)/$(LIBSO) $(LIBDIR)/$(TARGET)
|
|
+endif
|
|
|
|
relabel:
|
|
/sbin/restorecon $(SHLIBDIR)/$(LIBSO)
|
|
--
|
|
2.13.6
|
|
|