d6a4807f94
Drop upstream patch: 0001-sh-Fix-building-with-gcc5-6.patch https://sourceware.org/git/?p=glibc.git;a=commit;h=d40dbe722f004f999b589de776f7e57e564dda01 0002-CVE-2017-1000366-Ignore-LD_LIBRARY_PATH-for-AT_SECUR.patch https://sourceware.org/git/?p=glibc.git;a=commit;h=f6110a8fee2ca36f8e2d2abecf3cba9fa7b8ea7d 0003-ld.so-Reject-overly-long-LD_PRELOAD-path-elements.patch https://sourceware.org/git/?p=glibc.git;a=commit;h=6d0ba622891bed9d8394eef1935add53003b12e8 0004-ld.so-Reject-overly-long-LD_AUDIT-path-elements.patch https://sourceware.org/git/?p=glibc.git;a=commit;h=81b82fb966ffbd94353f793ad17116c6088dedd9 0005-fix-binutils-2-29-build.patch https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff_plain;h=388b4f1a02f3a801965028bbfcd48d905638b797 0006-i686-Add-missing-IS_IN-libc-guards-to-vectorized-strcspn.patch https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff_plain;h=69052a3a95da37169a08f9e59b2cc1808312753c 0006-sh4-trap.patch https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff_plain;h=db3d848e154b00071f4a5e729d5884efad410109 But 2.26 version introduced quite a few regressions on x86, x86_64 and powerpc64le when float128 support was added. All these issues are now fixed in the glibc 2.26 stable branch. Backport patches from glibc 2.26 stable branch related to bug 21930. Take all patches listed in this bug report in order to have all fix for this issue [1] [2]. Fixes gnuradio build: [...]/sysroot/usr/include/boost/functional/hash/detail/hash_float.hpp: In function ‘std::size_t boost::hash_detail::float_hash_value(T)’: [...]/sysroot/usr/include/boost/functional/hash/detail/hash_float.hpp:210:21: error: expected primary-expression before ‘float’ switch (fpclassify(v)) ^ [...]/sysroot/usr/include/boost/functional/hash/detail/hash_float.hpp:210:21: error: expected primary-expression before ‘long’ switch (fpclassify(v)) ^ [...]/sysroot/usr/include/boost/functional/hash/detail/hash_float.hpp:210:21: error: found ‘:’ in nested-name-specifier, expected ‘::’ switch (fpclassify(v)) ^ [...]/sysroot/usr/include/boost/functional/hash/detail/hash_float.hpp:210:21: error: ‘_Float128’ is not a class or namespace switch (fpclassify(v)) ^ [...]/sysroot/usr/include/boost/functional/hash/detail/hash_float.hpp:210:21: error: ‘_Generic’ was not declared in this scope switch (fpclassify(v)) ^ Also backport fix for glibc bug 22146. Without this patch some C++ applications (jsoncpp, mesa3d and kodi) fail to build due to an issue while building the toolchain. A test in the libstdc++ configure script fail when -Os and float128 are used. See the bug report for details [3]. [1] https://sourceware.org/ml/libc-alpha/2017-08/msg00586.html [2] https://sourceware.org/bugzilla/show_bug.cgi?id=21930 [3] https://sourceware.org/bugzilla/show_bug.cgi?id=22146 Signed-off-by: Romain Naour <romain.naour@gmail.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
211 lines
5.9 KiB
Diff
211 lines
5.9 KiB
Diff
From 45970aa26d1af87b016ef95b4b35c566aeb6e841 Mon Sep 17 00:00:00 2001
|
|
From: "Gabriel F. T. Gomes" <gftg@linux.vnet.ibm.com>
|
|
Date: Tue, 22 Aug 2017 16:34:42 -0300
|
|
Subject: [PATCH] Provide a C++ version of iszero that does not use __MATH_TG
|
|
(bug 21930)
|
|
|
|
When signaling nans are enabled (with -fsignaling-nans), the C++ version
|
|
of iszero uses the fpclassify macro, which is defined with __MATH_TG.
|
|
However, when support for float128 is available, __MATH_TG uses the
|
|
builtin __builtin_types_compatible_p, which is only available in C mode.
|
|
|
|
This patch refactors the C++ version of iszero so that it uses function
|
|
overloading to select between the floating-point types, instead of
|
|
relying on fpclassify and __MATH_TG.
|
|
|
|
Tested for powerpc64le, s390x, x86_64, and with build-many-glibcs.py.
|
|
|
|
[BZ #21930]
|
|
* math/math.h [defined __cplusplus && defined __SUPPORT_SNAN__]
|
|
(iszero): New C++ implementation that does not use
|
|
fpclassify/__MATH_TG/__builtin_types_compatible_p, when
|
|
signaling nans are enabled, since __builtin_types_compatible_p
|
|
is a C-only feature.
|
|
* math/test-math-iszero.cc: When __HAVE_DISTINCT_FLOAT128 is
|
|
defined, include ieee754_float128.h for access to the union and
|
|
member ieee854_float128.ieee.
|
|
[__HAVE_DISTINCT_FLOAT128] (do_test): Call check_float128.
|
|
[__HAVE_DISTINCT_FLOAT128] (check_float128): New function.
|
|
* sysdeps/powerpc/powerpc64le/Makefile [subdir == math]
|
|
(CXXFLAGS-test-math-iszero.cc): Add -mfloat128 to the build
|
|
options of test-math-zero on powerpc64le.
|
|
|
|
(cherry picked from commit 42496114ec0eb7d6d039d05d4262e109951c600c)
|
|
[Romain rebase on glibc 2.26]
|
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
|
---
|
|
math/math.h | 33 +++++++++++++--
|
|
math/test-math-iszero.cc | 79 ++++++++++++++++++++++++++++++++++++
|
|
sysdeps/powerpc/powerpc64le/Makefile | 3 +-
|
|
3 files changed, 110 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/math/math.h b/math/math.h
|
|
index 60dfa31..7c0fc6d 100644
|
|
--- a/math/math.h
|
|
+++ b/math/math.h
|
|
@@ -513,15 +513,40 @@ inline int issignaling (_Float128 __val) { return __issignalingf128 (__val); }
|
|
# endif
|
|
# else /* __cplusplus */
|
|
extern "C++" {
|
|
+# ifdef __SUPPORT_SNAN__
|
|
+inline int
|
|
+iszero (float __val)
|
|
+{
|
|
+ return __fpclassifyf (__val) == FP_ZERO;
|
|
+}
|
|
+inline int
|
|
+iszero (double __val)
|
|
+{
|
|
+ return __fpclassify (__val) == FP_ZERO;
|
|
+}
|
|
+inline int
|
|
+iszero (long double __val)
|
|
+{
|
|
+# ifdef __NO_LONG_DOUBLE_MATH
|
|
+ return __fpclassify (__val) == FP_ZERO;
|
|
+# else
|
|
+ return __fpclassifyl (__val) == FP_ZERO;
|
|
+# endif
|
|
+}
|
|
+# if __HAVE_DISTINCT_FLOAT128
|
|
+inline int
|
|
+iszero (_Float128 __val)
|
|
+{
|
|
+ return __fpclassifyf128 (__val) == FP_ZERO;
|
|
+}
|
|
+# endif
|
|
+# else
|
|
template <class __T> inline bool
|
|
iszero (__T __val)
|
|
{
|
|
-# ifdef __SUPPORT_SNAN__
|
|
- return fpclassify (__val) == FP_ZERO;
|
|
-# else
|
|
return __val == 0;
|
|
-# endif
|
|
}
|
|
+# endif
|
|
} /* extern C++ */
|
|
# endif /* __cplusplus */
|
|
#endif /* Use IEC_60559_BFP_EXT. */
|
|
diff --git a/math/test-math-iszero.cc b/math/test-math-iszero.cc
|
|
index 027e972..5c07261 100644
|
|
--- a/math/test-math-iszero.cc
|
|
+++ b/math/test-math-iszero.cc
|
|
@@ -22,6 +22,13 @@
|
|
|
|
#include <limits>
|
|
|
|
+/* Support for _Float128 in std::numeric_limits is limited.
|
|
+ Include ieee754_float128.h and use the bitfields in the union
|
|
+ ieee854_float128.ieee_nan to build corner-case inputs. */
|
|
+#if __HAVE_DISTINCT_FLOAT128
|
|
+# include <ieee754_float128.h>
|
|
+#endif
|
|
+
|
|
static bool errors;
|
|
|
|
static void
|
|
@@ -72,12 +79,84 @@ check_type ()
|
|
std::numeric_limits<T>::has_denorm == std::denorm_absent);
|
|
}
|
|
|
|
+#if __HAVE_DISTINCT_FLOAT128
|
|
+static void
|
|
+check_float128 ()
|
|
+{
|
|
+ ieee854_float128 q;
|
|
+
|
|
+ q.d = 0.0Q;
|
|
+ CHECK (iszero (q.d), 1);
|
|
+ q.d = -0.0Q;
|
|
+ CHECK (iszero (q.d), 1);
|
|
+ q.d = 1.0Q;
|
|
+ CHECK (iszero (q.d), 0);
|
|
+ q.d = -1.0Q;
|
|
+ CHECK (iszero (q.d), 0);
|
|
+
|
|
+ /* Normal min. */
|
|
+ q.ieee.negative = 0;
|
|
+ q.ieee.exponent = 0x0001;
|
|
+ q.ieee.mantissa0 = 0x0000;
|
|
+ q.ieee.mantissa1 = 0x00000000;
|
|
+ q.ieee.mantissa2 = 0x00000000;
|
|
+ q.ieee.mantissa3 = 0x00000000;
|
|
+ CHECK (iszero (q.d), 0);
|
|
+ q.ieee.negative = 1;
|
|
+ CHECK (iszero (q.d), 0);
|
|
+
|
|
+ /* Normal max. */
|
|
+ q.ieee.negative = 0;
|
|
+ q.ieee.exponent = 0x7FFE;
|
|
+ q.ieee.mantissa0 = 0xFFFF;
|
|
+ q.ieee.mantissa1 = 0xFFFFFFFF;
|
|
+ q.ieee.mantissa2 = 0xFFFFFFFF;
|
|
+ q.ieee.mantissa3 = 0xFFFFFFFF;
|
|
+ CHECK (iszero (q.d), 0);
|
|
+ q.ieee.negative = 1;
|
|
+ CHECK (iszero (q.d), 0);
|
|
+
|
|
+ /* Infinity. */
|
|
+ q.ieee.negative = 0;
|
|
+ q.ieee.exponent = 0x7FFF;
|
|
+ q.ieee.mantissa0 = 0x0000;
|
|
+ q.ieee.mantissa1 = 0x00000000;
|
|
+ q.ieee.mantissa2 = 0x00000000;
|
|
+ q.ieee.mantissa3 = 0x00000000;
|
|
+ CHECK (iszero (q.d), 0);
|
|
+
|
|
+ /* Quiet NaN. */
|
|
+ q.ieee_nan.quiet_nan = 1;
|
|
+ q.ieee_nan.mantissa0 = 0x0000;
|
|
+ CHECK (iszero (q.d), 0);
|
|
+
|
|
+ /* Signaling NaN. */
|
|
+ q.ieee_nan.quiet_nan = 0;
|
|
+ q.ieee_nan.mantissa0 = 0x4000;
|
|
+ CHECK (iszero (q.d), 0);
|
|
+
|
|
+ /* Denormal min. */
|
|
+ q.ieee.negative = 0;
|
|
+ q.ieee.exponent = 0x0000;
|
|
+ q.ieee.mantissa0 = 0x0000;
|
|
+ q.ieee.mantissa1 = 0x00000000;
|
|
+ q.ieee.mantissa2 = 0x00000000;
|
|
+ q.ieee.mantissa3 = 0x00000001;
|
|
+ CHECK (iszero (q.d), 0);
|
|
+ q.ieee.negative = 1;
|
|
+ CHECK (iszero (q.d), 0);
|
|
+}
|
|
+#endif
|
|
+
|
|
static int
|
|
do_test (void)
|
|
{
|
|
check_type<float> ();
|
|
check_type<double> ();
|
|
check_type<long double> ();
|
|
+#if __HAVE_DISTINCT_FLOAT128
|
|
+ check_float128 ();
|
|
+#endif
|
|
return errors;
|
|
}
|
|
|
|
diff --git a/sysdeps/powerpc/powerpc64le/Makefile b/sysdeps/powerpc/powerpc64le/Makefile
|
|
index 19adbfa..dea2290 100644
|
|
--- a/sysdeps/powerpc/powerpc64le/Makefile
|
|
+++ b/sysdeps/powerpc/powerpc64le/Makefile
|
|
@@ -17,7 +17,8 @@ $(foreach suf,$(all-object-suffixes),$(objpfx)test-float128%$(suf)): CFLAGS += -
|
|
$(foreach suf,$(all-object-suffixes),$(objpfx)test-ifloat128%$(suf)): CFLAGS += -mfloat128
|
|
CFLAGS-libm-test-support-float128.c += -mfloat128
|
|
CFLAGS-test-math-issignaling.cc += -mfloat128
|
|
-$(objpfx)test-float128% $(objpfx)test-ifloat128%: \
|
|
+CFLAGS-test-math-iszero.cc += -mfloat128
|
|
+$(objpfx)test-float128% $(objpfx)test-ifloat128% $(objpfx)test-math-iszero: \
|
|
gnulib-tests += $(f128-loader-link)
|
|
endif
|
|
|
|
--
|
|
2.9.5
|
|
|