c128c5f3c7
When the host uses glibc 2.26 or newer, Flex will try to use the newly-introduced reallocarray() function, but as it would not define _GNU_SOURCE a segmentation fault would occur later on due to the compiler assumming that the function is implicitly defined. This issue manifests itself due to a crash of "stage1flex" during the Flex bootstrap: ./stage1flex -o stage1scan.c ./scan.l make[2]: *** [Makefile:1725: stage1scan.c] Segmentation fault (core dumped) This imports the patch from the upstream Git repository, and adds flags in the .mk file to rebuild the Autotools scripts and support files. Due to the latter, the patch to disable the documentation is changed so it modifies the .am file instead. Signed-off-by: Adrian Perez de Castro <aperez@igalia.com> [Arnout: - Add Adrian's Sob and upstream ref to new patch; - Keep patch 1 as patch 1; - Keep Vicente as author of path 1; - Add reason for autoreconf in a comment.] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
36 lines
1.1 KiB
Diff
36 lines
1.1 KiB
Diff
From ffa886a580929f26fd5e5a40c9c5334955c48553 Mon Sep 17 00:00:00 2001
|
|
From: Explorer09 <explorer09@gmail.com>
|
|
Date: Mon, 4 Sep 2017 10:47:33 +0800
|
|
Subject: [PATCH] build: AC_USE_SYSTEM_EXTENSIONS in configure.ac.
|
|
|
|
This would, e.g. define _GNU_SOURCE in config.h, enabling the
|
|
reallocarray() prototype in glibc 2.26+ on Linux systems with that
|
|
version of glibc.
|
|
|
|
Fixes #241.
|
|
|
|
Backported from: 24fd0551333e7eded87b64dd36062da3df2f6380
|
|
Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
|
|
---
|
|
configure.ac | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 55e774b..c879fe1 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -25,8 +25,10 @@
|
|
# autoconf requirements and initialization
|
|
|
|
AC_INIT([the fast lexical analyser generator],[2.6.4],[flex-help@lists.sourceforge.net],[flex])
|
|
+AC_PREREQ([2.60])
|
|
AC_CONFIG_SRCDIR([src/scan.l])
|
|
AC_CONFIG_AUX_DIR([build-aux])
|
|
+AC_USE_SYSTEM_EXTENSIONS
|
|
LT_INIT
|
|
AM_INIT_AUTOMAKE([1.11.3 -Wno-portability foreign check-news std-options dist-lzip parallel-tests subdir-objects])
|
|
AC_CONFIG_HEADER([src/config.h])
|
|
--
|
|
2.14.1
|
|
|