8a66ebabff
Context: The autobuilders were failing on the symbol _XData32 being in conflicts. A patch had been added to SDL to add a check to the configure.in Problem: Sometimes, the build would fail, because of an _XData32 symbol being in conflicts eventhrough the patch was here. What was happening: Following the classic buildroot workflow: - Extract - [...] - Apply 001 patch, which touches configure.in AND configure - Apply 002 patch, which touches configure.in - Invoke autogen.sh - [...] Right before running autogen.sh, we have configure.in which is more recent than configure, which is fine. We then, execute autogen.sh which, basically, runs autoconf. If your machine was lighty loaded, the time difference between configure.in and configure was really tiny (ms order), which seems to be neglected by autoconf. The results was that the configure was *NOT* generated. And our second patch was not taken into account. If your machine was under heavy load, the time difference between the two files would have been greater and then *maybe* picked up by autoconf. And then the configure file was re-generated. When the 0001 patch was introduced, SDL package did *NOT* run it's autogen.sh, which is why it touches also the configure. This came later, causing this behavior. Fixes: http://autobuild.buildroot.net/results/d1c/d1c36f634dbf6b6e5d18444c2a23dfd129202b80/ Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
26 lines
997 B
Diff
26 lines
997 B
Diff
[PATCH] configure.in: use correct directfb-config in version check
|
|
|
|
The configure script has just checked for the correct directfb-config
|
|
script, so also use it for the version check instead of whatever
|
|
might be in the path.
|
|
|
|
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
|
---
|
|
configure.in | 2 +-
|
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
|
|
|
Index: SDL-1.2.15/configure.in
|
|
===================================================================
|
|
--- SDL-1.2.15.orig/configure.in
|
|
+++ SDL-1.2.15/configure.in
|
|
@@ -1276,7 +1276,7 @@
|
|
else
|
|
set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
|
|
NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
|
|
- set -- `directfb-config --version | sed 's/\./ /g'`
|
|
+ set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
|
|
HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
|
|
if test $HAVE_VERSION -ge $NEED_VERSION; then
|
|
DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
|
|
|