6e6e8d37b5
Bump Python3 version to 3.6.2. Patches dropped: "Support PGEN_FOR_BUILD and FREEZE_IMPORTLIB_FOR_BUILD" Rationale: With commit 9d02f562961efd12d3c8317a10916db7f77330cc, code generation step of building CPython now became explicit (instead of always performed as a part of 'make' invocation) and more granular. We no longer need to use Parser/pgen at all and tricking the build system into using different Programs/_freeze_importlib can be done as a part of recipe. Additional info about the build change can be found at https://bugs.python.org/issue23404 Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
116 lines
4.0 KiB
Diff
116 lines
4.0 KiB
Diff
From bba0896a05e6406076893dd2f4c3b330e41082a6 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 22 Feb 2017 17:01:18 -0800
|
|
Subject: [PATCH] Add an option to disable installation of test modules
|
|
|
|
The Python standard distribution comes with many test modules, that
|
|
are not necessarly useful on embedded targets.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
[ Andrey Smirnov: ported to Python 3.6 ]
|
|
Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
|
|
---
|
|
Makefile.pre.in | 55 ++++++++++++++++++++++++++++++++++++-------------------
|
|
configure.ac | 5 +++++
|
|
2 files changed, 41 insertions(+), 19 deletions(-)
|
|
|
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index 4ce917ab8d..4110fff4ac 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1194,8 +1194,28 @@ maninstall: altmaninstall
|
|
|
|
# Install the library
|
|
XMLLIBSUBDIRS= xml xml/dom xml/etree xml/parsers xml/sax
|
|
-LIBSUBDIRS= tkinter tkinter/test tkinter/test/test_tkinter \
|
|
- tkinter/test/test_ttk site-packages test \
|
|
+
|
|
+LIBSUBDIRS= tkinter site-packages \
|
|
+ asyncio \
|
|
+ collections concurrent concurrent/futures encodings \
|
|
+ email email/mime \
|
|
+ ensurepip ensurepip/_bundled \
|
|
+ html json http dbm xmlrpc \
|
|
+ sqlite3 \
|
|
+ logging csv wsgiref urllib \
|
|
+ lib2to3 lib2to3/fixes lib2to3/pgen2 \
|
|
+ ctypes ctypes/macholib \
|
|
+ idlelib idlelib/Icons \
|
|
+ distutils distutils/command $(XMLLIBSUBDIRS) \
|
|
+ importlib \
|
|
+ turtledemo \
|
|
+ multiprocessing multiprocessing/dummy \
|
|
+ unittest \
|
|
+ venv venv/scripts venv/scripts/common venv/scripts/posix \
|
|
+ curses pydoc_data
|
|
+
|
|
+TESTSUBDIRS= tkinter/test tkinter/test/test_tkinter \
|
|
+ tkinter/test/test_ttk test \
|
|
test/audiodata \
|
|
test/capath test/data \
|
|
test/cjkencodings test/decimaltestdata test/xmltestdata \
|
|
@@ -1229,29 +1249,26 @@ LIBSUBDIRS= tkinter tkinter/test tkinter/test/test_tkinter \
|
|
test/test_importlib/namespace_pkgs/project3/parent/child \
|
|
test/test_importlib/namespace_pkgs/module_and_namespace_package \
|
|
test/test_importlib/namespace_pkgs/module_and_namespace_package/a_test \
|
|
- asyncio \
|
|
test/test_asyncio \
|
|
- collections concurrent concurrent/futures encodings \
|
|
- email email/mime test/test_email test/test_email/data \
|
|
- ensurepip ensurepip/_bundled \
|
|
- html json test/test_json http dbm xmlrpc \
|
|
- sqlite3 sqlite3/test \
|
|
- logging csv wsgiref urllib \
|
|
- lib2to3 lib2to3/fixes lib2to3/pgen2 lib2to3/tests \
|
|
+ test/test_email test/test_email/data \
|
|
+ test/test_json \
|
|
+ sqlite3/test \
|
|
+ lib2to3/tests \
|
|
lib2to3/tests/data lib2to3/tests/data/fixers \
|
|
lib2to3/tests/data/fixers/myfixes \
|
|
- ctypes ctypes/test ctypes/macholib \
|
|
- idlelib idlelib/Icons idlelib/idle_test \
|
|
- distutils distutils/command distutils/tests $(XMLLIBSUBDIRS) \
|
|
- importlib test/test_importlib test/test_importlib/builtin \
|
|
+ ctypes/test \
|
|
+ idlelib/idle_test \
|
|
+ distutils/tests \
|
|
+ test/test_importlib test/test_importlib/builtin \
|
|
test/test_importlib/extension test/test_importlib/frozen \
|
|
test/test_importlib/import_ test/test_importlib/source \
|
|
test/test_tools test/test_warnings test/test_warnings/data \
|
|
- turtledemo \
|
|
- multiprocessing multiprocessing/dummy \
|
|
- unittest unittest/test unittest/test/testmock \
|
|
- venv venv/scripts venv/scripts/common venv/scripts/posix \
|
|
- curses pydoc_data
|
|
+ unittest/test unittest/test/testmock
|
|
+
|
|
+ifeq (@TEST_MODULES@,yes)
|
|
+LIBSUBDIRS += $(TESTSUBDIRS)
|
|
+endif
|
|
+
|
|
libinstall: build_all $(srcdir)/Modules/xxmodule.c
|
|
@for i in $(SCRIPTDIR) $(LIBDEST); \
|
|
do \
|
|
diff --git a/configure.ac b/configure.ac
|
|
index d5ee2aedfb..f924937fe1 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3112,6 +3112,11 @@ if test "$posix_threads" = "yes"; then
|
|
AC_CHECK_FUNCS(pthread_atfork)
|
|
fi
|
|
|
|
+AC_SUBST(TEST_MODULES)
|
|
+
|
|
+AC_ARG_ENABLE(test-modules,
|
|
+ AS_HELP_STRING([--disable-test-modules], [disable test modules]),
|
|
+ [ TEST_MODULES="${enableval}" ], [ TEST_MODULES=yes ])
|
|
|
|
# Check for enable-ipv6
|
|
AH_TEMPLATE(ENABLE_IPV6, [Define if --enable-ipv6 is specified])
|
|
--
|
|
2.13.5
|
|
|