9c47cd5b64
This patch only add the native cwiid library and a couple of tools. The 2 first cwiid patches are retrieved from upstream and fix build issues, so does the 3rd one. The 4th patch allows to disable wmgui build, so allows to reduce to number of dependencies. Cc: Eric Jarrige <eric.jarrige@armadeus.org> Signed-off-by: Samuel Martin <s.martin49@gmail.com>
65 lines
1.6 KiB
Diff
65 lines
1.6 KiB
Diff
From dbb578450974db5decc24560da4aeaed838849a1 Mon Sep 17 00:00:00 2001
|
|
From: Samuel Martin <s.martin49@gmail.com>
|
|
Date: Thu, 2 Jan 2014 14:03:07 +0100
|
|
Subject: [PATCH 2/2] configure: make wmgui build optional
|
|
|
|
So, make gtk-2 and glib2 dependencies optional (only needed by wmgui)
|
|
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
---
|
|
Makefile.in | 2 +-
|
|
configure.ac | 17 +++++++++++++----
|
|
2 files changed, 14 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 6d3ac98..3d2fb45 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -3,7 +3,7 @@
|
|
include @top_builddir@/defs.mak
|
|
|
|
LIB_DIRS = libcwiid
|
|
-BIN_DIRS = wmgui wminput lswm
|
|
+BIN_DIRS = @WMGUI@ wminput lswm
|
|
DOC_DIRS = man doc
|
|
ifdef PYTHON
|
|
BIND_DIRS = python
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 82ca3e1..d146cb6 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -15,6 +15,11 @@ if test "$YACC" != "bison -y"; then
|
|
AC_MSG_ERROR([bison not found])
|
|
fi
|
|
|
|
+AC_ARG_ENABLE(
|
|
+ [wmgui],
|
|
+ [AS_HELP_STRING([--disable-wmgui],[Do not build wmgui binary (also drop the gtk-2/glib2 dependency)])],
|
|
+ [ENABLE_WMGUI="$enableval"],[ENABLE_WMGUI=yes])
|
|
+
|
|
AC_ARG_WITH(
|
|
[python],
|
|
[AS_HELP_STRING([--without-python],[compile without python support])],
|
|
@@ -98,10 +103,14 @@ else
|
|
fi
|
|
AC_SUBST(LDCONFIG)
|
|
|
|
-pkg_modules="gtk+-2.0 >= 2.0.0 gthread-2.0"
|
|
-PKG_CHECK_MODULES([GTK], [$pkg_modules])
|
|
-AC_SUBST(GTK_CFLAGS)
|
|
-AC_SUBST(GTK_LIBS)
|
|
+AS_IF(
|
|
+ [test "x$ENABLE_WMGUI" = xyes],
|
|
+ [pkg_modules="gtk+-2.0 >= 2.0.0 gthread-2.0" ;
|
|
+ PKG_CHECK_MODULES([GTK], [$pkg_modules])
|
|
+ AC_SUBST(GTK_CFLAGS)
|
|
+ AC_SUBST(GTK_LIBS)
|
|
+ AC_SUBST(WMGUI, wmgui)]
|
|
+)
|
|
|
|
AC_OUTPUT(
|
|
[Makefile]
|
|
--
|
|
1.8.5.2
|
|
|