09a565d940
Fixes the following security issue: - CVE-2020-25692: A NULL pointer dereference was found in OpenLDAP server and was fixed in openldap 2.4.55, during a request for renaming RDNs. An unauthenticated attacker could remotely crash the slapd process by sending a specially crafted request, causing a Denial of Service. - CVE-2020-25709: Assertion failure in CSN normalization with invalid input - CVE-2020-25710: Assertion failure in CSN normalization with invalid input Signed-off-by: Francois Perrad <francois.perrad@gadz.org> [Peter: add CVE info] Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
75 lines
2.9 KiB
Diff
75 lines
2.9 KiB
Diff
Fix stripping when cross-compiling
|
|
|
|
Probably-Signed-off-by: Dave Bender <bender@benegon.com>
|
|
[yann.morin.1998@free.fr: patch was made by Dave, but he
|
|
forgot his SoB line, so I added it]
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
|
|
diff -rupN openldap-2.4.40/build/shtool openldap-2.4.40-br/build/shtool
|
|
--- openldap-2.4.40/build/shtool 2014-09-18 21:48:49.000000000 -0400
|
|
+++ openldap-2.4.40-br/build/shtool 2015-01-21 13:21:35.689829372 -0500
|
|
@@ -981,7 +981,7 @@ install )
|
|
if [ ".$opt_t" = .yes ]; then
|
|
echo "strip $dsttmp" 1>&2
|
|
fi
|
|
- strip $dsttmp || shtool_exit $?
|
|
+ $STRIP $dsttmp || shtool_exit $?
|
|
fi
|
|
if [ ".$opt_o" != . ]; then
|
|
if [ ".$opt_t" = .yes ]; then
|
|
diff -rupN openldap-2.4.40/build/top.mk openldap-2.4.40-br/build/top.mk
|
|
--- openldap-2.4.40/build/top.mk 2014-09-18 21:48:49.000000000 -0400
|
|
+++ openldap-2.4.40-br/build/top.mk 2015-01-21 13:23:41.027810097 -0500
|
|
@@ -59,7 +59,7 @@ INSTALL_PROGRAM = $(INSTALL)
|
|
INSTALL_DATA = $(INSTALL) -m 644
|
|
INSTALL_SCRIPT = $(INSTALL)
|
|
|
|
-STRIP = -s
|
|
+STRIP_OPTS = -s
|
|
|
|
LINT = lint
|
|
5LINT = 5lint
|
|
diff -rupN openldap-2.4.40/clients/tools/Makefile.in openldap-2.4.40-br/clients/tools/Makefile.in
|
|
--- openldap-2.4.40/clients/tools/Makefile.in 2014-09-18 21:48:49.000000000 -0400
|
|
+++ openldap-2.4.40-br/clients/tools/Makefile.in 2015-01-21 13:23:35.827727946 -0500
|
|
@@ -120,7 +120,7 @@ install-local: FORCE
|
|
-$(MKDIR) $(DESTDIR)$(bindir)
|
|
@( \
|
|
for prg in $(PROGRAMS); do \
|
|
- $(LTINSTALL) $(INSTALLFLAGS) $(STRIP) -m 755 $$prg$(EXEEXT) \
|
|
+ $(LTINSTALL) $(INSTALLFLAGS) $(STRIP_OPTS) -m 755 $$prg$(EXEEXT) \
|
|
$(DESTDIR)$(bindir); \
|
|
done \
|
|
)
|
|
diff -rupN openldap-2.4.40/configure.in openldap-2.4.40-br/configure.in
|
|
--- openldap-2.4.40/configure.in 2014-09-18 21:48:49.000000000 -0400
|
|
+++ openldap-2.4.40-br/configure.in 2015-01-16 15:50:48.874816786 -0500
|
|
@@ -668,6 +668,15 @@ if test -z "${AR}"; then
|
|
fi
|
|
fi
|
|
|
|
+if test -z "${STRIP}"; then
|
|
+ AC_CHECK_PROGS(STRIP,strip,missing)
|
|
+
|
|
+ if test "${STRIP}" = "missing" ; then
|
|
+ AC_MSG_ERROR([Unable to locate strip(1) or suitable replacement. Check PATH or set STRIP.])
|
|
+ fi
|
|
+fi
|
|
+
|
|
+
|
|
AC_LIBTOOL_WIN32_DLL
|
|
AC_LIBTOOL_DLOPEN
|
|
AC_PROG_LIBTOOL
|
|
diff -rupN openldap-2.4.40/servers/slapd/Makefile.in openldap-2.4.40-br/servers/slapd/Makefile.in
|
|
--- openldap-2.4.40/servers/slapd/Makefile.in 2015-01-16 15:04:52.507473256 -0500
|
|
+++ openldap-2.4.40-br/servers/slapd/Makefile.in 2015-01-16 15:05:02.299627229 -0500
|
|
@@ -378,7 +378,7 @@ install-local-srv: install-slapd install
|
|
install-slapd: FORCE
|
|
-$(MKDIR) $(DESTDIR)$(libexecdir)
|
|
-$(MKDIR) $(DESTDIR)$(localstatedir)/run
|
|
- $(LTINSTALL) $(INSTALLFLAGS) $(STRIP) -m 755 \
|
|
+ $(LTINSTALL) $(INSTALLFLAGS) $(STRIP_OPTS) -m 755 \
|
|
slapd$(EXEEXT) $(DESTDIR)$(libexecdir)
|
|
@for i in $(SUBDIRS); do \
|
|
if test -d $$i && test -f $$i/Makefile ; then \
|