4b3425c0bb
Pyhton 2.7.3 includes several security fixes. See: http://www.python.org/download/releases/2.7.3/ Also fixes the patch making sqlite optional and remove the symlink patch (which has been fixed upstream). Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
58 lines
1.5 KiB
Diff
58 lines
1.5 KiB
Diff
Add option to disable the sqlite3 module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
|
|
---
|
|
Makefile.pre.in | 24 +++++++++++++++++-------
|
|
configure.in | 9 +++++++++
|
|
2 file changed, 9 insertions(+)
|
|
|
|
Index: Python-2.7.2/configure.in
|
|
===================================================================
|
|
--- Python-2.7.2.orig/configure.in
|
|
+++ Python-2.7.2/configure.in
|
|
@@ -2407,6 +2407,15 @@
|
|
esac])
|
|
fi
|
|
|
|
+AC_SUBST(SQLITE3)
|
|
+AC_ARG_ENABLE(sqlite3,
|
|
+ AS_HELP_STRING([--disable-sqlite3], [disable sqlite3]),
|
|
+ [ SQLITE3="${enableval}" ], [ SQLITE3=yes ])
|
|
+
|
|
+if test "$SQLITE3" = "no" ; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
|
|
+fi
|
|
+
|
|
AC_SUBST(PYDOC)
|
|
|
|
AC_ARG_ENABLE(pydoc,
|
|
Index: Python-2.7.2/Makefile.pre.in
|
|
===================================================================
|
|
--- Python-2.7.2.orig/Makefile.pre.in
|
|
+++ Python-2.7.2/Makefile.pre.in
|
|
@@ -875,7 +874,7 @@
|
|
lib-tk/test/test_ttk test test/data \
|
|
test/cjkencodings test/decimaltestdata test/xmltestdata test/subprocessdata \
|
|
test/tracedmodules email/test email/test/data \
|
|
- json/tests sqlite3/test bsddb/test \
|
|
+ json/tests bsddb/test \
|
|
ctypes/test distutils/tests unittest/test
|
|
endif
|
|
|
|
@@ -884,6 +882,13 @@
|
|
LIBSUBDIRS += pydoc_data
|
|
endif
|
|
|
|
+ifeq (@SQLITE3@,yes)
|
|
+LIBSUBDIRS += sqlite3
|
|
+ifeq (@TEST_MODULES@,yes)
|
|
+LIBSUBDIRS += sqlite3/test
|
|
+endif
|
|
+endif
|
|
+
|
|
libinstall: build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
|
|
@for i in $(SCRIPTDIR) $(LIBDEST); \
|
|
do \
|