a3366b2705
Commit6eacea5ae0
accidentally removed these changes in merge_config.sh:0f56304521
("merge_config.sh: create temporary files in /tmp")28fac3973b
("merge_config.sh: add br2-external support") Changes were lost because commits just changed files, but didn't add patches. Therefore not only restore our changes, but also add (updated) patches. Missing0f56304521
caused breaking merge_config.sh when used in out of tree build: $ make -C buildroot O=$PWD/output defconfig ... $ cd output $ echo 'BR2_TARGET_GENERIC_HOSTNAME="test"' > test.frag $ ../buildroot/support/kconfig/merge_config.sh .config test.frag Using .config as base Merging test.frag umask 0022 && make -C /home/test/buildroot O=/home/test/output/. alldefconfig GEN /home/test/output/Makefile *** Can't read seed configuration "./.tmp.config.qIcpASpUyh"! make[1]: *** [Makefile:925: alldefconfig] Error 1 make: *** [Makefile:16: _all] Error 2 Fixes:6eacea5ae0
support/kconfig: bump to kconfig from Linux 4.17-rc2 Signed-off-by: Petr Vorel <petr.vorel@gmail.com> Reported-by: Erico Nunes <nunes.erico@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
28 lines
1.0 KiB
Diff
28 lines
1.0 KiB
Diff
commit 0f56304521db42bd2c05867fd78a247104a4ad95
|
|
Author: Henrique Marks <henrique.marks@datacom.ind.br>
|
|
Date: Mon, 7 Dec 2015 12:08:45 -0200
|
|
|
|
merge_config.sh: create temporary files in /tmp
|
|
|
|
Creating temporary files in /tmp (or the path pointed by $TMPDIR) allows the
|
|
buildroot top directory to be read-only and shareable between multible builds.
|
|
This follows what other scripts do, e.g. check-kernel-headers.sh.
|
|
|
|
Signed-off-by: Henrique Marks <henrique.marks@datacom.ind.br>
|
|
Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
|
|
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
|
|
|
|
Index: kconfig/merge_config.sh
|
|
===================================================================
|
|
--- kconfig.orig/merge_config.sh
|
|
+++ kconfig/merge_config.sh
|
|
@@ -100,7 +100,7 @@ fi
|
|
|
|
MERGE_LIST=$*
|
|
SED_CONFIG_EXP="s/^\(# \)\{0,1\}\(CONFIG_[a-zA-Z0-9_]*\)[= ].*/\2/p"
|
|
-TMP_FILE=$(mktemp ./.tmp.config.XXXXXXXXXX)
|
|
+TMP_FILE=$(mktemp -t .tmp.config.XXXXXXXXXX)
|
|
|
|
echo "Using $INITFILE as base"
|
|
cat $INITFILE > $TMP_FILE
|