6a16e1631f
I re-did the patches: one patch per change, patch configure.in instead of the configure script itself, a few more issues fixed. This should hopefully make the patches acceptable for upstream, or at least make it easier to migrate them on version bumps. This also fixes compilation with musl libc. Signed-off-by: Maarten ter Huurne <maarten@treewalker.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
44 lines
1.5 KiB
Diff
44 lines
1.5 KiB
Diff
From: Maarten ter Huurne <maarten@treewalker.org>
|
|
Date: Mon, 15 Sep 2014 02:27:09 +0200
|
|
Subject: Ensure that installation dirs exist before copying files into them
|
|
|
|
Since the "install_bin" target requires the installation directories
|
|
to exist, it should depend on the "installdirs" target. The previous
|
|
approach of having "install" depend on "installdirs" is not reliable.
|
|
|
|
For example, in a parallel build, there was no guarantee that
|
|
"installdirs" would be finished before "install_bin" runs. Also if
|
|
the user requested only "install_bin" to be made, "installdirs" would
|
|
be skipped altogether.
|
|
|
|
Signed-off-by: Maarten ter Huurne <maarten@treewalker.org>
|
|
---
|
|
Makefile.in | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 860f351..f0fe08d 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -82,7 +82,7 @@ screen: $(OFILES)
|
|
$(CC) -c -I. -I$(srcdir) $(M_CFLAGS) $(CPPFLAGS) $(DEFS) \
|
|
$(OPTIONS) $(CFLAGS) $<
|
|
|
|
-install_bin: .version screen
|
|
+install_bin: .version screen installdirs
|
|
$(INSTALL_PROGRAM) screen $(DESTDIR)$(bindir)/$(SCREEN)
|
|
-chown root $(DESTDIR)$(bindir)/$(SCREEN)
|
|
-chmod 4755 $(DESTDIR)$(bindir)/$(SCREEN)
|
|
@@ -94,7 +94,7 @@ endif
|
|
cp $(srcdir)/utf8encodings/?? $(DESTDIR)$(SCREENENCODINGS)
|
|
|
|
###############################################################################
|
|
-install: installdirs install_bin
|
|
+install: install_bin
|
|
cd doc ; $(MAKE) install
|
|
-if [ -d /usr/lib/terminfo ]; then \
|
|
PATH="$$PATH:/usr/5bin" tic ${srcdir}/terminfo/screeninfo.src; \
|
|
--
|
|
1.8.4.5
|
|
|