kumquat-buildroot/package/rust/0002-configure-use-default-python-interpreter.patch
Romain Naour 02703108ec package/rust: allow using python3 interpreter
Fedora packaging use python3 as python interpreter since rust 1.24.0 [1]
by removing python2 tests from configure script [2].

Using python3 will help to remove python2 in a near future.

[1] 216b2d2771
[2] 216b2d2771/f/rust.spec (_314)

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Titouan Christophe <titouan.christophe@railnova.eu>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Patrick Havelange <patrick.havelange@essensium.com>
Tested-by: Titouan Christophe <titouan.christophe@railnova.eu>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-05-29 23:11:02 +02:00

38 lines
882 B
Diff

From aca7abb537f5caf1c9f027cf65dd0f53fb664e73 Mon Sep 17 00:00:00 2001
From: Romain Naour <romain.naour@gmail.com>
Date: Tue, 26 May 2020 18:24:25 +0200
Subject: [PATCH] configure: use default python interpreter
Don't try to use python2 if available, use the python interpreter available
in ouput/host/bin/python whatever the python version is.
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
configure | 12 ------------
1 file changed, 12 deletions(-)
diff --git a/configure b/configure
index eeb8d081d34..6014a982f47 100755
--- a/configure
+++ b/configure
@@ -2,16 +2,4 @@
script="$(dirname $0)"/src/bootstrap/configure.py
-try() {
- cmd=$1
- shift
- T=$($cmd --version 2>/dev/null)
- if [ $? -eq 0 ]; then
- exec $cmd "$script" "$@"
- fi
-}
-
-try python2.7 "$@"
-try python27 "$@"
-try python2 "$@"
exec python $script "$@"
--
2.25.4