d2afa01f76
Update all appropriate version numbers as well as SHAs and MD5s as well as repbasing BR's patches on top of 3.6.1 codebase (new github repo tree, v3.6.1 tag was used). Note that patch: [PATCH] Change the install location of _sysconfigdata.py was dropped due to the fact taht build system now adds platform specific suffix to sysconfigdata's name, so each platform's file should have a unique name and distutils now allows to specify which sysconfigdata is used via _PYTHON_SYSCONFIGDATA_NAME see:c4b53afce4
92dec548ff
and patches: [PATCH] distutils/sysconfig: use sysconfigdata [PATCH] setup.py: do not add invalid header locations [PATCH] Do not harcode invalid path to ncursesw headers was dropped since it looks like it made it's way upstream, see:409482251b
1351c31aa9
e13c3201fb
respectively. Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
36 lines
1.3 KiB
Diff
36 lines
1.3 KiB
Diff
From 0d63a5df20abeea7a5f10eaceed376151565e766 Mon Sep 17 00:00:00 2001
|
|
From: Christophe Vu-Brugier <cvubrugier@fastmail.fm>
|
|
Date: Wed, 23 Dec 2015 11:44:30 +0100
|
|
Subject: [PATCH] Do not adjust the shebang of Python scripts for
|
|
cross-compilation
|
|
|
|
The copy_scripts() method in distutils copies the scripts listed in
|
|
the setup file and adjusts the first line to refer to the current
|
|
Python interpreter. When cross-compiling, this means that the adjusted
|
|
shebang refers to the host Python interpreter.
|
|
|
|
This patch modifies copy_scripts() to preserve the shebang when
|
|
cross-compilation is detected.
|
|
|
|
Signed-off-by: Christophe Vu-Brugier <cvubrugier@fastmail.fm>
|
|
---
|
|
Lib/distutils/command/build_scripts.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Lib/distutils/command/build_scripts.py b/Lib/distutils/command/build_scripts.py
|
|
index ccc70e6..d6d5419 100644
|
|
--- a/Lib/distutils/command/build_scripts.py
|
|
+++ b/Lib/distutils/command/build_scripts.py
|
|
@@ -91,7 +91,7 @@ class build_scripts(Command):
|
|
adjust = True
|
|
post_interp = match.group(1) or b''
|
|
|
|
- if adjust:
|
|
+ if adjust and not '_python_sysroot' in os.environ:
|
|
log.info("copying and adjusting %s -> %s", script,
|
|
self.build_dir)
|
|
updated_files.append(outfile)
|
|
--
|
|
2.9.3
|
|
|