d2afa01f76
Update all appropriate version numbers as well as SHAs and MD5s as well as repbasing BR's patches on top of 3.6.1 codebase (new github repo tree, v3.6.1 tag was used). Note that patch: [PATCH] Change the install location of _sysconfigdata.py was dropped due to the fact taht build system now adds platform specific suffix to sysconfigdata's name, so each platform's file should have a unique name and distutils now allows to specify which sysconfigdata is used via _PYTHON_SYSCONFIGDATA_NAME see:c4b53afce4
92dec548ff
and patches: [PATCH] distutils/sysconfig: use sysconfigdata [PATCH] setup.py: do not add invalid header locations [PATCH] Do not harcode invalid path to ncursesw headers was dropped since it looks like it made it's way upstream, see:409482251b
1351c31aa9
e13c3201fb
respectively. Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
32 lines
1.3 KiB
Diff
32 lines
1.3 KiB
Diff
From 0458813245e8ba3d5b567cd53303cbe975144e95 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 23 Dec 2015 11:36:00 +0100
|
|
Subject: [PATCH] Don't look in /usr/lib/termcap for libraries
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
setup.py | 5 +----
|
|
1 file changed, 1 insertion(+), 4 deletions(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index c5bce21..c5eb97d 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -786,12 +786,9 @@ class PyBuildExt(build_ext):
|
|
pass # Issue 7384: Already linked against curses or tinfo.
|
|
elif curses_library:
|
|
readline_libs.append(curses_library)
|
|
- elif self.compiler.find_library_file(lib_dirs +
|
|
- ['/usr/lib/termcap'],
|
|
- 'termcap'):
|
|
+ elif self.compiler.find_library_file(lib_dirs, 'termcap'):
|
|
readline_libs.append('termcap')
|
|
exts.append( Extension('readline', ['readline.c'],
|
|
- library_dirs=['/usr/lib/termcap'],
|
|
extra_link_args=readline_extra_link_args,
|
|
libraries=readline_libs) )
|
|
else:
|
|
--
|
|
2.9.3
|
|
|