ba2850edcc
Backport a patch from SuperTux project:
61d3b63abc
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
39 lines
1.3 KiB
Diff
39 lines
1.3 KiB
Diff
From 61d3b63abcba8e9615dcb8a3d1fc026bf7f8d5f8 Mon Sep 17 00:00:00 2001
|
|
From: Jacob Burroughs <jburroughs@trustwave.com>
|
|
Date: Thu, 23 Jun 2016 13:03:47 -0500
|
|
Subject: [PATCH] Fix builds with modern GCC
|
|
|
|
From SuperTux project:
|
|
https://github.com/SuperTux/physfs/commit/61d3b63abcba8e9615dcb8a3d1fc026bf7f8d5f8
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
|
---
|
|
CMakeLists.txt | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 2a371af..94c4844 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -50,7 +50,7 @@ endif()
|
|
# Add some gcc-specific command lines.
|
|
if(CMAKE_COMPILER_IS_GNUCC)
|
|
# Always build with debug symbols...you can strip it later.
|
|
- add_definitions(-g -pipe -Werror -fsigned-char)
|
|
+ add_definitions(-g -pipe -fsigned-char)
|
|
|
|
# Stupid BeOS generates warnings in the system headers.
|
|
if(NOT BEOS)
|
|
@@ -304,7 +304,7 @@ if(PHYSFS_BUILD_TEST)
|
|
if(READLINE_LIBRARY)
|
|
set(HAVE_SYSTEM_READLINE TRUE)
|
|
set(TEST_PHYSFS_LIBS ${TEST_PHYSFS_LIBS} ${READLINE_LIBRARY} ${CURSES_LIBRARY})
|
|
- include_directories(${READLINE_H} ${HISTORY_H})
|
|
+ include_directories(SYSTEM ${READLINE_H} ${HISTORY_H})
|
|
add_definitions(-DPHYSFS_HAVE_READLINE=1)
|
|
endif()
|
|
endif()
|
|
--
|
|
2.9.3
|
|
|