9ef0e9afba
Patches downloaded from Github are not stable, so bring them in the tree. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
36 lines
1.3 KiB
Diff
36 lines
1.3 KiB
Diff
From 3770bdc4fa7b9059db5cd2aa8bb09b50fa15e456 Mon Sep 17 00:00:00 2001
|
|
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
Date: Fri, 12 Feb 2016 19:25:02 +0100
|
|
Subject: [PATCH] Fix usage of __GLIBC_PREREQ for non-glibc toolchains
|
|
|
|
The way __GLIBC_PREREQ() is currently used means that it's evaluated
|
|
even if __GLIBC__ is not defined. But obviously, __GLIBC_PREREQ will
|
|
not exist if __GLIBC__ is not defined, causing build failures on C
|
|
libraries not defining __GLIBC__ such as the musl C library.
|
|
|
|
Patch originally taken from:
|
|
https://github.com/voidlinux/void-packages/blob/master/srcpkgs/numactl/patches/musl.patch
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
[Bernd: Reworked to fix uClibc]
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
[Thomas: improve patch description.]
|
|
[Upstream commit: https://github.com/numactl/numactl/commit/3770bdc4fa7b9059db5cd2aa8bb09b50fa15e456.]
|
|
---
|
|
syscall.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/syscall.c b/syscall.c
|
|
index 4589b85..37782d9 100644
|
|
--- a/syscall.c
|
|
+++ b/syscall.c
|
|
@@ -115,7 +115,7 @@
|
|
|
|
#endif
|
|
|
|
-#if defined(__GLIBC__) && __GLIBC_PREREQ(2, 11)
|
|
+#if defined(__GLIBC_PREREQ) && __GLIBC_PREREQ(2, 11)
|
|
|
|
/* glibc 2.11 seems to have working 6 argument sycall. Use the
|
|
glibc supplied syscall in this case.
|