f837251785
This commit removes the dependencies on MMU and dynamic libraries. In order to build v4l2 utilities such as compliancy tools like v4l2-compliance or cec-compliance, v4-utils can now be built without dynamic libraries support. In that case the v4l-utils parts which depends on dynamic library support are not built: - libv4l & libv4lconvert libraries - libv4l plugins - rds-ctl utility - contrib test utilities The rest of the utilities are built. Signed-off-by: Hugues Fruchet <hugues.fruchet@st.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
44 lines
1.9 KiB
Diff
44 lines
1.9 KiB
Diff
From e2f317f5b9a1ba888325ac938de26b402664c271 Mon Sep 17 00:00:00 2001
|
|
From: Hugues Fruchet <hugues.fruchet@st.com>
|
|
Date: Wed, 17 May 2017 10:03:09 +0200
|
|
Subject: [PATCH] configure.ac: revisit v4l2-ctl/compliance using libv4l
|
|
variable naming
|
|
|
|
USE_V4L2_CTL and USE_V4L2_COMPLIANCE are used to trig the fact that
|
|
v4l2-ctl and v4l2-compliance are using libv4l2, change namings to not
|
|
confuse with overall v4l2-ctl/compliance utilities building.
|
|
|
|
Signed-off-by: Hugues Fruchet <hugues.fruchet@st.com>
|
|
Signed-off-by: Hans Verkuil <hans.verkuil@cisco.com>
|
|
---
|
|
configure.ac | 8 ++++----
|
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 3c70969..5f20fc8 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -461,8 +461,8 @@ AM_COND_IF([WITH_QV4L2], [USE_QV4L2="yes"], [USE_QV4L2="no"])
|
|
AM_COND_IF([WITH_V4L_PLUGINS], [USE_V4L_PLUGINS="yes"], [USE_V4L_PLUGINS="no"])
|
|
AM_COND_IF([WITH_V4L_WRAPPERS], [USE_V4L_WRAPPERS="yes"], [USE_V4L_WRAPPERS="no"])
|
|
AM_COND_IF([WITH_GCONV], [USE_GCONV="yes"], [USE_GCONV="no"])
|
|
-AM_COND_IF([WITH_V4L2_CTL_LIBV4L], [USE_V4L2_CTL="yes"], [USE_V4L2_CTL="no"])
|
|
-AM_COND_IF([WITH_V4L2_COMPLIANCE_LIBV4L], [USE_V4L2_COMPLIANCE="yes"], [USE_V4L2_COMPLIANCE="no"])
|
|
+AM_COND_IF([WITH_V4L2_CTL_LIBV4L], [USE_V4L2_CTL_LIBV4L="yes"], [USE_V4L2_CTL_LIBV4L="no"])
|
|
+AM_COND_IF([WITH_V4L2_COMPLIANCE_LIBV4L], [USE_V4L2_COMPLIANCE_LIBV4L="yes"], [USE_V4L2_COMPLIANCE_LIBV4L="no"])
|
|
AS_IF([test "x$alsa_pkgconfig" = "xtrue"], [USE_ALSA="yes"], [USE_ALSA="no"])
|
|
|
|
AC_OUTPUT
|
|
@@ -497,6 +497,6 @@ compile time options summary
|
|
dvbv5-daemon : $USE_DVBV5_REMOTE
|
|
v4lutils : $USE_V4LUTILS
|
|
qv4l2 : $USE_QV4L2
|
|
- v4l2-ctl uses libv4l : $USE_V4L2_CTL
|
|
- v4l2-compliance uses libv4l: $USE_V4L2_COMPLIANCE
|
|
+ v4l2-ctl uses libv4l : $USE_V4L2_CTL_LIBV4L
|
|
+ v4l2-compliance uses libv4l: $USE_V4L2_COMPLIANCE_LIBV4L
|
|
EOF
|
|
--
|
|
1.9.1
|
|
|