84a2723568
Static build with musl fails since bump to version 2020.04 in commit
fe97212976
because LDFLAGS, which contains
-static, is not passed resulting in the following build failure:
/tmp/instance-1/output-1/host/lib/gcc/arm-buildroot-linux-musleabihf/10.3.0/../../../../arm-buildroot-linux-musleabihf/bin/ld: /tmp/instance-1/output-1/host/lib/gcc/arm-buildroot-linux-musleabihf/10.3.0/libgcc.a(_dvmd_lnx.o): in function `__aeabi_ldiv0':
/tmp/instance-1/output-1/build/host-gcc-final-10.3.0/build/arm-buildroot-linux-musleabihf/libgcc/../../../libgcc/config/arm/lib1funcs.S:1499: undefined reference to `raise'
collect2: error: ld returned 1 exit status
Fixes:
- http://autobuild.buildroot.org/results/d71aba27ff0c7711f2cb67261183506f25217a5f
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
35 lines
1.0 KiB
Diff
35 lines
1.0 KiB
Diff
From 3b89170333ef0fdfffee14751ce3e1d66d7dfa00 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Tue, 14 Sep 2021 19:08:02 +0200
|
|
Subject: [PATCH] tools/Makefile: fix {C,LD}FLAGS with CROSS_BUILD_TOOLS
|
|
|
|
When CROSS_BUILD_TOOLS is set, set KBUILD_HOST{CF,LD}FLAGS to
|
|
{C,LD}FLAGS otherwise CC will be used with HOST{C,LD}FLAGS which seems
|
|
wrong.
|
|
|
|
It should be noted that, for an unknown reason, overriding
|
|
HOST{C,LD}FLAGS don't work.
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
tools/Makefile | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/tools/Makefile b/tools/Makefile
|
|
index 4a86321f64..98bb92990d 100644
|
|
--- a/tools/Makefile
|
|
+++ b/tools/Makefile
|
|
@@ -316,7 +316,8 @@ subdir- += env
|
|
|
|
ifneq ($(CROSS_BUILD_TOOLS),)
|
|
override HOSTCC = $(CC)
|
|
-override HOSTCFLAGS = $(CFLAGS)
|
|
+override KBUILD_HOSTCFLAGS = $(CFLAGS)
|
|
+override KBUILD_HOSTLDFLAGS = $(LDFLAGS)
|
|
|
|
quiet_cmd_crosstools_strip = STRIP $^
|
|
cmd_crosstools_strip = $(STRIP) $^; touch $@
|
|
--
|
|
2.33.0
|
|
|