255e7b5d91
- will need some program_invocation_name touchup, from the looks. Sounds like Ulf is supporting this: http://buildroot.uclibc.org/lists/buildroot/2007-August/004651.html Ulf> Go ahead, since it is permanently broken. It was for ARM for the most part. Some others did work, fwiw.
117 lines
2.4 KiB
Diff
117 lines
2.4 KiB
Diff
--- openssh-3.6.1p1/Makefile.in.orig 2003-03-20 17:34:34.000000000 -0700
|
|
+++ openssh-3.6.1p1/Makefile.in 2003-04-25 17:09:00.000000000 -0600
|
|
@@ -27,7 +27,7 @@
|
|
RAND_HELPER=$(libexecdir)/ssh-rand-helper
|
|
PRIVSEP_PATH=@PRIVSEP_PATH@
|
|
SSH_PRIVSEP_USER=@SSH_PRIVSEP_USER@
|
|
-STRIP_OPT=@STRIP_OPT@
|
|
+STRIP_OPT=
|
|
|
|
PATHS= -DSSHDIR=\"$(sysconfdir)\" \
|
|
-D_PATH_SSH_PROGRAM=\"$(SSH_PROGRAM)\" \
|
|
|
|
--- openssh-3.6.1p1/S50sshd Fri Sep 27 05:21:58 2002
|
|
+++ openssh-3.6.1p1/S50sshd Mon Mar 17 14:55:00 2003
|
|
@@ -0,0 +1,64 @@
|
|
+#!/bin/sh
|
|
+#
|
|
+# sshd Starts sshd.
|
|
+#
|
|
+
|
|
+# Make sure the ssh-keygen progam exists
|
|
+[ -f /usr/bin/ssh-keygen ] || exit 0
|
|
+
|
|
+# Check for the SSH1 RSA key
|
|
+if [ ! -f /etc/ssh_host_key ] ; then
|
|
+ echo Generating RSA Key...
|
|
+ /usr/bin/ssh-keygen -t rsa1 -f /etc/ssh_host_key -C '' -N ''
|
|
+fi
|
|
+
|
|
+# Check for the SSH2 RSA key
|
|
+if [ ! -f /etc/ssh_host_rsa_key ] ; then
|
|
+ echo Generating RSA Key...
|
|
+ /usr/bin/ssh-keygen -t rsa -f /etc/ssh_host_rsa_key -C '' -N ''
|
|
+fi
|
|
+
|
|
+# Check for the SSH2 DSA key
|
|
+if [ ! -f /etc/ssh_host_dsa_key ] ; then
|
|
+ echo Generating DSA Key...
|
|
+ echo THIS CAN TAKE A MINUTE OR TWO DEPENDING ON YOUR PROCESSOR!
|
|
+ echo
|
|
+ /usr/bin/ssh-keygen -t dsa -f /etc/ssh_host_dsa_key -C '' -N ''
|
|
+fi
|
|
+
|
|
+umask 077
|
|
+
|
|
+start() {
|
|
+ echo -n "Starting sshd: "
|
|
+ /usr/sbin/sshd
|
|
+ touch /var/lock/sshd
|
|
+ echo "OK"
|
|
+}
|
|
+stop() {
|
|
+ echo -n "Stopping sshd: "
|
|
+ killall sshd
|
|
+ rm -f /var/lock/sshd
|
|
+ echo "OK"
|
|
+}
|
|
+restart() {
|
|
+ stop
|
|
+ start
|
|
+}
|
|
+
|
|
+case "$1" in
|
|
+ start)
|
|
+ start
|
|
+ ;;
|
|
+ stop)
|
|
+ stop
|
|
+ ;;
|
|
+ restart|reload)
|
|
+ restart
|
|
+ ;;
|
|
+ *)
|
|
+ echo $"Usage: $0 {start|stop|restart}"
|
|
+ exit 1
|
|
+esac
|
|
+
|
|
+exit $?
|
|
+
|
|
--- openssh-4.6p1.oorig/sshd_config 2006-07-24 06:06:47.000000000 +0200
|
|
+++ openssh-4.6p1/sshd_config 2007-06-28 15:58:49.000000000 +0200
|
|
@@ -11,7 +11,7 @@
|
|
# default value.
|
|
|
|
#Port 22
|
|
-#Protocol 2,1
|
|
+Protocol 2
|
|
#AddressFamily any
|
|
#ListenAddress 0.0.0.0
|
|
#ListenAddress ::
|
|
@@ -83,9 +83,11 @@
|
|
#AllowTcpForwarding yes
|
|
#GatewayPorts no
|
|
#X11Forwarding no
|
|
+X11Forwarding yes
|
|
#X11DisplayOffset 10
|
|
#X11UseLocalhost yes
|
|
#PrintMotd yes
|
|
+PrintMotd no
|
|
#PrintLastLog yes
|
|
#TCPKeepAlive yes
|
|
#UseLogin no
|
|
@@ -102,8 +104,12 @@
|
|
# no default banner path
|
|
#Banner /some/path
|
|
|
|
+ClientAliveInterval 15
|
|
+ClientAliveCountMax 4
|
|
+AcceptEnv LANG LC_*
|
|
+
|
|
# override default of no subsystems
|
|
-Subsystem sftp /usr/libexec/sftp-server
|
|
+Subsystem sftp /usr/sbin/sftp-server
|
|
|
|
# Example of overriding settings on a per-user basis
|
|
#Match User anoncvs
|