7e960dc9da
Even though jumping from 2.7.3 to 2.7.6 looks like a minor version bump, it is in fact a fairly significant one, because a good number of changes to help cross-compilation have been merged into Python upstream. Therefore, most of our patches are affected by this change. In detail, this commit: * Renames all the patches to follow the naming convention of patches in Buildroot: the patch file names should not have any version number. * The patches numbered above 100, that add configuration options to disable certain modules of the Python standard library, are only renamed and slightly adapted, they didn't change that much. * The patches numbered below 100 are almost entirely rewritten: many of the cross-compilation problems that used to exist in Python 2.7.3 no longer exist, and the number of remaining problems is smaller, and can be fixed with smaller patches. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
69 lines
1.8 KiB
Diff
69 lines
1.8 KiB
Diff
Add an option to disable the tk module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
|
|
---
|
|
Makefile.pre.in | 14 ++++++++++----
|
|
configure.in | 9 +++++++++
|
|
2 files changed, 19 insertions(+), 4 deletions(-)
|
|
|
|
Index: b/Makefile.pre.in
|
|
===================================================================
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -934,8 +934,7 @@
|
|
plat-mac/lib-scriptpackages/SystemEvents \
|
|
plat-mac/lib-scriptpackages/Terminal
|
|
PLATMACPATH=:plat-mac:plat-mac/lib-scriptpackages
|
|
-LIBSUBDIRS= lib-tk \
|
|
- site-packages \
|
|
+LIBSUBDIRS= site-packages \
|
|
encodings compiler hotshot \
|
|
email email/mime \
|
|
json \
|
|
@@ -947,9 +946,7 @@
|
|
lib-old \
|
|
curses $(MACHDEPS)
|
|
|
|
-TESTSUBDIRS = lib-tk/test lib-tk/test/test_tkinter \
|
|
- lib-tk/test/test_ttk \
|
|
- test test/audiodata test/data \
|
|
+TESTSUBDIRS = test test/audiodata test/data \
|
|
test/cjkencodings test/decimaltestdata test/xmltestdata test/subprocessdata \
|
|
test/tracedmodules \
|
|
email/test email/test/data \
|
|
@@ -980,6 +977,12 @@
|
|
TESTSUBDIRS += sqlite3/test
|
|
endif
|
|
|
|
+ifeq (@TK@,yes)
|
|
+LIBSUBDIRS += lib-tk
|
|
+TESTSUBDIRS += lib-tk/test lib-tk/test/test_tkinter \
|
|
+ lib-tk/test/test_ttk
|
|
+endif
|
|
+
|
|
libinstall: build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
|
|
@for i in $(SCRIPTDIR) $(LIBDEST); \
|
|
do \
|
|
Index: b/configure.ac
|
|
===================================================================
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2622,6 +2622,15 @@
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
|
|
fi
|
|
|
|
+AC_SUBST(TK)
|
|
+AC_ARG_ENABLE(tk,
|
|
+ AS_HELP_STRING([--disable-tk], [disable tk]),
|
|
+ [ TK="${enableval}" ], [ TK=yes ])
|
|
+
|
|
+if test "$TK" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
|
|
+fi
|
|
+
|
|
AC_SUBST(PYDOC)
|
|
|
|
AC_ARG_ENABLE(pydoc,
|