0a227142c9
this release includes my 2 requests, see http://www.freelists.org/post/luajit/LuaJIT-on-Buildroot Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
24 lines
788 B
Diff
24 lines
788 B
Diff
Don't strip the library and binary
|
|
|
|
This allows Buildroot to do it if needed, but only if needed.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/src/Makefile
|
|
===================================================================
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -665,12 +665,10 @@
|
|
$(LUAJIT_SO): $(LJVMCORE_O)
|
|
$(E) "DYNLINK $@"
|
|
$(Q)$(TARGET_LD) $(TARGET_ASHLDFLAGS) -o $@ $(LJVMCORE_DYNO) $(TARGET_ALIBS)
|
|
- $(Q)$(TARGET_STRIP) $@
|
|
|
|
$(LUAJIT_T): $(TARGET_O) $(LUAJIT_O) $(TARGET_DEP)
|
|
$(E) "LINK $@"
|
|
$(Q)$(TARGET_LD) $(TARGET_ALDFLAGS) -o $@ $(LUAJIT_O) -lluajit -L. $(TARGET_ALIBS)
|
|
- $(Q)$(TARGET_STRIP) $@
|
|
$(E) "OK Successfully built LuaJIT"
|
|
|
|
##############################################################################
|